blob: 05134614a5e4ce1239dc57157ac34c26c73c5344 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Cross-platform audio output library and plugins"
2DESCRIPTION = "Libao is a cross-platform audio library that allows programs to \
3 output audio using a simple API on a wide variety of platforms."
4SECTION = "multimedia"
5HOMEPAGE = "https://www.xiph.org/ao/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
10SRC_URI="http://downloads.xiph.org/releases/ao/${BP}.tar.gz"
11SRC_URI[md5sum] = "9f5dd20d7e95fd0dd72df5353829f097"
12SRC_URI[sha256sum] = "03ad231ad1f9d64b52474392d63c31197b0bc7bd416e58b1c10a329a5ed89caf"
13
14inherit autotools
15
16PACKAGES += "${BPN}-ckport"
17PACKAGES_DYNAMIC += "^${BPN}-plugin-.*"
18
19do_install_append () {
20 find "${D}" -name '*.la' -exec rm -f {} +
21}
22
23python populate_packages_prepend () {
24 rootdir = bb.data.expand('${libdir}/ao/plugins-4', d)
25 rootdir_dbg = bb.data.expand('${libdir}/ao/plugins-4/.debug', d)
26 do_split_packages(d, rootdir, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s', description='AO %s plugin')
27 do_split_packages(d, rootdir_dbg, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s-dbg', description='AO %s plugin debug data')
28}
29
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
32PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
33FILES_${BPN}-ckport = "${libdir}/ckport"