blob: e466cc2327f5af8cb9df47375cc41e83109f1c54 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16
17DEPENDS = "libxml2 python"
18TOOLCHAIN = "gcc"
19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
23 file://0001-configure-Pass-linker-specific-options-with-Wl.patch \
24 file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040027 file://0001-Add-configure-time-check-for-gettid-API.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040028 "
Brad Bishop26bdd442019-08-16 17:08:17 -040029SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f"
30SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce"
Brad Bishopc342db32019-05-15 21:57:59 -040031
32inherit autotools useradd systemd pkgconfig
33
34USERADD_PACKAGES = "${PN}"
35GROUPADD_PARAM_${PN} = "-f -r opensaf"
36USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
37
38SYSTEMD_SERVICE_${PN} += "opensafd.service"
39SYSTEMD_AUTO_ENABLE = "disable"
40
41PACKAGECONFIG[systemd] = ",,systemd"
42PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi"
43PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
44
45PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
46
47PKGLIBDIR="${libdir}"
48CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
51
52do_install_append() {
53 cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
54 rm -fr "${D}${localstatedir}/lock"
55 rm -fr "${D}${localstatedir}/run"
56 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
57 rmdir --ignore-fail-on-non-empty "${D}${datadir}/java"
58 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
59 install -d ${D}${sysconfdir}/init.d
60 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
61 fi
62}
63
64FILES_${PN} += "${systemd_unitdir}/system/*.service"
65FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
66
67INSANE_SKIP_${PN} = "dev-so"
68
69RDEPENDS_${PN} += "bash python"
70
71# http://errors.yoctoproject.org/Errors/Details/186970/
72EXCLUDE_FROM_WORLD_libc-musl = "1"