blob: 9d0da33e377dfb3de42f1b9b959c6075ddc31a82 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl readline gmp bison-native"
7
8UPSTREAM_CHECK_URI = "https://www.netfilter.org/projects/nftables/files/"
9
10SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
11SRC_URI[md5sum] = "e2facbcad6c5d9bd87a0bf5081a31522"
12SRC_URI[sha256sum] = "ead3bb68ed540bfbb87a96f2b69c3d65ab0c2a0c3f6e739a395c09377d1b4fce"
13
14inherit autotools manpages pkgconfig
15
16PACKAGECONFIG ?= "python"
17PACKAGECONFIG[man] = "--enable--man-doc, --disable-man-doc"
18PACKAGECONFIG[python] = "--with-python-bin=${PYTHON}, --with-python-bin="", python3"
19
20inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
21
22ASNEEDED = ""
23
24RRECOMMENDS_${PN} += "kernel-module-nf-tables"
25
26PACKAGES =+ "${PN}-python"
27FILES_${PN}-python = "${libdir_native}/${PYTHON_DIR}"
28RDEPENDS_${PN}-python = "python3-core python3-json"