blob: 22cb88ac123cd3ea3f4f86997043677ed0ef2b8e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Virtual Server administration Utility"
2HOMEPAGE = "http://www.linux-vs.org/software/index.html"
3DESCRIPTION = "Ipvsadm is used to set up, maintain or inspect the virtual server \
4table in the Linux kernel. The Linux Virtual Server can be used to \
5build scalable network services based on a cluster of two or more nodes. \
6The active node of the cluster redirects service requests to a \
7collection of server hosts that will actually perform the services. \
8Supported features include two protocols (TCP and UDP), three packet-forwarding \
9methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
10(round robin, weighted round robin, least-connec-tion, weighted least-connection, \
11locality-based least-connection, locality-based least-connection with replication, \
12destination-hashing, and source-hashing)."
13SECTION = "net"
14LICENSE = "GPL-2.0"
15LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=b4e40069f15598d0e3fe2aa177e5ec77"
16
17DEPENDS += "libnl popt"
18
Brad Bishop26bdd442019-08-16 17:08:17 -040019SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/utils/kernel/ipvsadm/${BP}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020 file://0001-Modify-the-Makefile-for-cross-compile.patch \
21 file://0003-ipvsadm-remove-dependency-on-bash.patch \
22 file://makefile-add-ldflags.patch \
23"
24
Brad Bishop26bdd442019-08-16 17:08:17 -040025SRC_URI[md5sum] = "97f11b6af1920fde5a9d9eac0d7f9e50"
26SRC_URI[sha256sum] = "95573d70df473c9f63fc4ac496c044c69e3a6de7ccac119922210c0b44cd7a0c"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
28UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/ipvsadm"
29
30do_compile() {
31 oe_runmake \
32 CC="${CC} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3 -L${STAGING_LIBDIR}" \
33 all
34}
35
36do_install() {
37 sed -i -e "s;SBIN\t\t= \$(BUILD_ROOT)/sbin;SBIN\t\t= \$(BUILD_ROOT)/$base_sbindir;" ${S}/Makefile
38 oe_runmake 'BUILD_ROOT=${D}' install
39}
40
41inherit pkgconfig