blob: 4f7f8aa3efc9c41e2aa953aab61b5809827d144b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4require nis.inc
5
6DESCRIPTION = " \
7Multithreaded NIS bind service (ypbind-mt). \
8ypbind-mt is a complete new implementation of a NIS \
9binding daemon for Linux. It has the following \
10features. Supports ypbind protocol V1 and V2. \
11Uses threads for better response. Supports multiple \
12domain bindings. Supports /var/yp/binding/* file \
13for Linux libc 4/5 and glibc 2.x. Supports a list \
14of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \
16\
17This is the final IPv4-only version of ypbind-mt. \
18"
19HOMEPAGE = "https://github.com/thkukuk/ypbind-mt/"
20DEPENDS = " \
21 yp-tools \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23 "
24DEPENDS_append_libc-musl = " bsd-headers nss"
25RDEPENDS_${PN} += "yp-tools"
26
27# ypbind-mt now provides all the functionality of ypbind
28# and is used in place of it.
29PROVIDES += "ypbind"
30
31SRC_URI = "https://github.com/thkukuk/ypbind-mt/releases/download/v${PV}/${BPN}-${PV}.tar.xz \
32 file://ypbind.init \
33 file://ypbind.service \
34 file://0001-dns_hosts-Fix-build-with-musl.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040035 file://0001-Add-configure-time-check-for-gettid-API.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040036 "
37SRC_URI[md5sum] = "7cf89641fdc128d0919207e4b7caaf1d"
38SRC_URI[sha256sum] = "0696c0263c4fd48a4ff2ce6c109f05f37aab0f71646d81cb22c7c28591bf80eb"
39
40inherit systemd update-rc.d
41
42SYSTEMD_SERVICE_${PN} = "ypbind.service"
43INITSCRIPT_NAME = "ypbind"
44INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
45
46CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
47
48CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/nss3"
49
50do_install_append () {
51 install -d ${D}${sysconfdir}/init.d
52 install -d ${D}${sysconfdir}/rcS.d
53
54 install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
55
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
58}
59
60
61RPROVIDES_${PN} += "${PN}-systemd"
62RREPLACES_${PN} += "${PN}-systemd"
63RCONFLICTS_${PN} += "${PN}-systemd"