blob: df455dbe30c4e7dbe512ae285e8305a0c29c395b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
3HOMEPAGE = "https://www.stunnel.org/"
4SECTION = "net"
5# Note: Linking stunnel statically or dynamically with other modules is making
6# a combined work based on stunnel. Thus, the terms and conditions of the GNU
7# General Public License cover the whole combination.
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c7acb24399f540ea323acb0366aecdbe"
10
11DEPENDS = "autoconf-archive libnsl2 openssl"
12
13SRC_URI = "ftp://ftp.stunnel.org/stunnel/archive/5.x/${BP}.tar.gz \
14 file://fix-openssl-no-des.patch \
15"
16
Brad Bishop26bdd442019-08-16 17:08:17 -040017SRC_URI[md5sum] = "7b41592034ede114e8c4e058fc8c238b"
18SRC_URI[sha256sum] = "90de69f41c58342549e74c82503555a6426961b29af3ed92f878192727074c62"
Brad Bishopc342db32019-05-15 21:57:59 -040019
20inherit autotools
21
22PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} libwrap"
23
24PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
25PACKAGECONFIG[libwrap] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
26PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
27
28EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
29
30# When cross compiling, configure defaults to nobody, but provides no option to change it.
31EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
32
33# stunnel3 is a Perl wrapper to allow use of the legacy stunnel 3.x commandline
34# syntax with stunnel >= 4.05
35PACKAGES =+ "stunnel3"
36FILES_stunnel3 = "${bindir}/stunnel3"
37RDEPENDS_stunnel3 += "${PN} perl"