blob: 0607c9d774c565dfebc4eab8864244ab4ac41f88 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Unbound is a validating, recursive, and caching DNS resolver"
2DESCRIPTION = "Unbound's design is a set of modular components which incorporate \
3 features including enhanced security (DNSSEC) validation, Internet Protocol \
4 Version 6 (IPv6), and a client resolver library API as an integral part of the \
5 architecture"
6
7HOMEPAGE = "https://www.unbound.net/"
8SECTION = "net"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
11
12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=http;branch=master \
13 file://0001-contrib-add-yocto-compatible-startup-scripts.patch \
14"
15SRCREV="ee06aaaad99dc4d6b73f915d98f05c506885b98a"
16
17inherit autotools pkgconfig systemd update-rc.d
18
19DEPENDS = "openssl libevent libtool-native bison-native expat"
20RDEPENDS_${PN} = "bash openssl-bin daemonize"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
25 --with-ssl=${STAGING_EXECPREFIXDIR} \
26 libtool=${TARGET_PREFIX}libtool \
27"
28
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile systemd', d)}"
31PACKAGECONFIG[dnscrypt] = "--enable-dnscrypt, --disable-dnscrypt, libsodium"
32PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
33PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
34
35do_install_append() {
36 install -d ${D}${systemd_unitdir}/system
37 install -m 0644 ${B}/contrib/unbound.service ${D}${systemd_unitdir}/system
38
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0755 ${S}/contrib/unbound.init ${D}${sysconfdir}/init.d/unbound
41}
42
43SYSTEMD_SERVICE_${PN} = "${BPN}.service"
44
45INITSCRIPT_NAME = "unbound"
46INITSCRIPT_PARAMS = "defaults"