blob: bab5a6ae6b17d59b6ad5325bcbdec54311839b0c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "openldap virtual/libiconv"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
27 file://0001-Fix-configure.ac.patch \
28 file://zabbix-agent.service \
29"
30
31SRC_URI[md5sum] = "489d21b464277c0d412155c7e5611a8f"
32SRC_URI[sha256sum] = "4445f26c025009681c29c9b350aa6c4ee7b124ddcaf1609ae36c55997bcb8cf2"
33
34inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
35
36SYSTEMD_PACKAGES = "${PN}"
37SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
38SYSTEMD_AUTO_ENABLE = "enable"
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM_${PN} = "-r zabbix"
42USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
43 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
44"
45
46KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
47
48EXTRA_OECONF = " \
49 --enable-dependency-tracking \
50 --enable-agent \
51 --enable-ipv6 \
52 --with-net-snmp \
53 --with-ldap=${STAGING_EXECPREFIXDIR} \
54 --with-jabber \
55 --with-unixodbc \
56 --with-ssh2 \
57 --with-sqlite3 \
58"
59CFLAGS_append = " -lldap -llber"
60
61do_configure_prepend() {
62 export KERNEL_VERSION="${KERNEL_VERSION}"
63}
64
65do_install_append() {
66 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
67 install -d ${D}${systemd_unitdir}/system
68 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
69 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
70 fi
71}
72
73FILES_${PN} += "${libdir}"
74
75RDEPENDS_${PN} = "logrotate"