blob: 69ee1d476be202a89846915659bbfe1ca0ace25b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig bash-completion systemd
12
Brad Bishop26bdd442019-08-16 17:08:17 -040013SRCREV = "ed17fd14608d8de072c8c090ffc5fcf78c4f48ff"
Brad Bishop19323692019-04-05 15:28:33 -040014SRC_URI = "git://github.com/pmem/ndctl.git"
15
Brad Bishop26bdd442019-08-16 17:08:17 -040016DEPENDS = "kmod udev json-c keyutils"
Brad Bishop19323692019-04-05 15:28:33 -040017
18S = "${WORKDIR}/git"
19
20EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
21
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
23PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
24
25do_configure_prepend() {
26 ${S}/autogen.sh
27}
28
29SYSTEMD_SERVICE_${PN} = "ndctl-monitor.service"
30SYSTEMD_AUTO_ENABLE_${PN} = "disable"
Brad Bishop26bdd442019-08-16 17:08:17 -040031
32FILES_${PN} += "${datadir}/daxctl/daxctl.conf"