blob: d84fcaecc909976b980d2fd80958534bc5713043 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "Different utilities from Android"
2SECTION = "console/utils"
3LICENSE = "Apache-2.0 & GPL-2.0 & BSD-2-Clause & BSD-3-Clause"
4LIC_FILES_CHKSUM = " \
5 file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10 \
6 file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
7 file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=8bef8e6712b1be5aa76af1ebde9d6378 \
8 file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
9"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "libbsd libpcre zlib libcap"
Brad Bishop19323692019-04-05 15:28:33 -040011DEPENDS_append_class-target = " openssl"
Patrick Williamsddad1a12017-02-23 20:36:32 -060012
Patrick Williamsddad1a12017-02-23 20:36:32 -060013ANDROID_MIRROR = "android.googlesource.com"
Patrick Williamsddad1a12017-02-23 20:36:32 -060014
Brad Bishop316dfdd2018-06-25 12:45:53 -040015# matches with android-5.1.1_r37
16SRCREV_core = "2314b110bdebdbfd2d94c502282f9e57c849897e"
17SRCREV_extras = "3ecbe8d841df96127d7855661293e5ab6ba6c205"
18SRCREV_libhardware = "be55eb1f4d840c82ffaf7c47460df17ff5bc4d9b"
19SRCREV_libselinux = "07e9e1339ad1ba608acfba9dce2d0f474b252feb"
20SRCREV_build = "16e987def3d7d8f7d30805eb95cef69e52a87dbc"
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022SRC_URI = " \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 git://${ANDROID_MIRROR}/platform/system/core;name=core;protocol=https;nobranch=1;destsuffix=git/system/core \
24 git://${ANDROID_MIRROR}/platform/system/extras;name=extras;protocol=https;nobranch=1;destsuffix=git/system/extras \
25 git://${ANDROID_MIRROR}/platform/hardware/libhardware;name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \
26 git://${ANDROID_MIRROR}/platform/external/libselinux;name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \
27 git://${ANDROID_MIRROR}/platform/build;name=build;protocol=https;nobranch=1;destsuffix=git/build \
28 file://core/0001-adb-remove-selinux-extensions.patch;patchdir=system/core \
29 file://core/0002-adb-Use-local-sockets-where-appropriate.patch;patchdir=system/core \
30 file://core/0003-adb-define-shell-command.patch;patchdir=system/core \
31 file://core/0004-adb-Fix-build-on-big-endian-systems.patch;patchdir=system/core \
32 file://core/0005-adb-add-base64-implementation.patch;patchdir=system/core \
33 file://core/0006-adb-Musl-fixes.patch;patchdir=system/core \
34 file://core/0007-adb-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
35 file://core/0008-adb-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
36 file://core/0009-mkbootimg-Add-dt-parameter-to-specify-DT-image.patch;patchdir=system/core \
37 file://core/0010-Use-linux-capability.h-on-linux-systems-too.patch;patchdir=system/core \
38 file://core/0011-Remove-bionic-specific-calls.patch;patchdir=system/core \
39 file://core/0012-Fix-implicit-declaration-of-stlcat-strlcopy-function.patch;patchdir=system/core \
Brad Bishop19323692019-04-05 15:28:33 -040040 file://core/adb_libssl_11.diff;patchdir=system/core \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 file://extras/0001-ext4_utils-remove-selinux-extensions.patch;patchdir=system/extras \
42 file://extras/0002-ext4_utils-add-o-argument-to-preserve-ownership.patch;patchdir=system/extras \
43 file://libselinux/0001-Remove-bionic-specific-calls.patch;patchdir=external/libselinux \
Brad Bishop26bdd442019-08-16 17:08:17 -040044 file://libselinux/0001-libselinux-Do-not-define-gettid-if-glibc-2.30-is-use.patch;patchdir=external/libselinux \
Patrick Williamsddad1a12017-02-23 20:36:32 -060045 file://android-tools-adbd.service \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046 file://gitignore \
Patrick Williamsddad1a12017-02-23 20:36:32 -060047 file://adb.mk;subdir=${BPN} \
48 file://adbd.mk;subdir=${BPN} \
49 file://ext4_utils.mk;subdir=${BPN} \
50 file://fastboot.mk;subdir=${BPN} \
51 file://mkbootimg.mk;subdir=${BPN} \
52"
53
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054
Patrick Williamsddad1a12017-02-23 20:36:32 -060055S = "${WORKDIR}/git"
56B = "${WORKDIR}/${BPN}"
57
Brad Bishop6e60e8b2018-02-01 10:27:11 -050058# http://errors.yoctoproject.org/Errors/Details/133881/
59ARM_INSTRUCTION_SET_armv4 = "arm"
60ARM_INSTRUCTION_SET_armv5 = "arm"
61
Brad Bishop19323692019-04-05 15:28:33 -040062COMPATIBLE_HOST_powerpc = "(null)"
63COMPATIBLE_HOST_powerpc64 = "(null)"
64
Patrick Williamsddad1a12017-02-23 20:36:32 -060065inherit systemd
66
67SYSTEMD_SERVICE_${PN} = "android-tools-adbd.service"
68
Patrick Williamsddad1a12017-02-23 20:36:32 -060069# Find libbsd headers during native builds
70CC_append_class-native = " -I${STAGING_INCDIR}"
71CC_append_class-nativesdk = " -I${STAGING_INCDIR}"
72
73TOOLS = "adb fastboot ext4_utils mkbootimg adbd"
74
75# Adb needs sys/capability.h, which is not available for native*
76TOOLS_class-native = "fastboot ext4_utils mkbootimg"
77TOOLS_class-nativesdk = "fastboot ext4_utils mkbootimg"
78
79do_compile() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080 cp ${WORKDIR}/gitignore ${S}/.gitignore
81
Patrick Williamsddad1a12017-02-23 20:36:32 -060082 # Setting both variables below causing our makefiles to not work with
83 # implicit make rules
84 unset CFLAGS
85 unset CPPFLAGS
86
87 export SRCDIR=${S}
88
89 case "${HOST_ARCH}" in
90 arm)
91 export android_arch=linux-arm
92 ;;
93 aarch64)
94 export android_arch=linux-arm64
95 ;;
96 mips|mipsel)
97 export android_arch=linux-mips
98 ;;
Brad Bishop19323692019-04-05 15:28:33 -040099 mips64|mips64el)
100 export android_arch=linux-mips64
101 ;;
Patrick Williamsddad1a12017-02-23 20:36:32 -0600102 powerpc|powerpc64)
103 export android_arch=linux-ppc
104 ;;
105 i586|x86_64)
106 export android_arch=linux-x86
107 ;;
108 esac
109
110 for tool in ${TOOLS}; do
111 mkdir -p ${B}/${tool}
112 oe_runmake -f ${B}/${tool}.mk -C ${B}/${tool}
113 done
114}
115
116do_install() {
117 if echo ${TOOLS} | grep -q "ext4_utils" ; then
118 install -D -p -m0755 ${S}/system/core/libsparse/simg_dump.py ${D}${bindir}/simg_dump
119 install -D -p -m0755 ${S}/system/extras/ext4_utils/mkuserimg.sh ${D}${bindir}/mkuserimg
120
121 install -m0755 ${B}/ext4_utils/ext2simg ${D}${bindir}
122 install -m0755 ${B}/ext4_utils/ext4fixup ${D}${bindir}
123 install -m0755 ${B}/ext4_utils/img2simg ${D}${bindir}
124 install -m0755 ${B}/ext4_utils/make_ext4fs ${D}${bindir}
125 install -m0755 ${B}/ext4_utils/simg2img ${D}${bindir}
126 install -m0755 ${B}/ext4_utils/simg2simg ${D}${bindir}
127 fi
128
129 if echo ${TOOLS} | grep -q "adb " ; then
130 install -d ${D}${bindir}
131 install -m0755 ${B}/adb/adb ${D}${bindir}
132 fi
133
134 if echo ${TOOLS} | grep -q "adbd" ; then
135 install -d ${D}${bindir}
136 install -m0755 ${B}/adbd/adbd ${D}${bindir}
137 fi
138
139 # Outside the if statement to avoid errors during do_package
140 install -D -p -m0644 ${WORKDIR}/android-tools-adbd.service \
141 ${D}${systemd_unitdir}/system/android-tools-adbd.service
142
143 if echo ${TOOLS} | grep -q "fastboot" ; then
144 install -d ${D}${bindir}
145 install -m0755 ${B}/fastboot/fastboot ${D}${bindir}
146 fi
147
148 if echo ${TOOLS} | grep -q "mkbootimg" ; then
149 install -d ${D}${bindir}
150 install -m0755 ${B}/mkbootimg/mkbootimg ${D}${bindir}
151 fi
152}
153
154PACKAGES += "${PN}-fstools"
155
156RDEPENDS_${BPN} = "${BPN}-conf bash"
157
158FILES_${PN}-fstools = "\
159 ${bindir}/ext2simg \
160 ${bindir}/ext4fixup \
161 ${bindir}/img2simg \
162 ${bindir}/make_ext4fs \
163 ${bindir}/simg2img \
164 ${bindir}/simg2simg \
165 ${bindir}/simg_dump \
166 ${bindir}/mkuserimg \
167"
168
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500169BBCLASSEXTEND = "native"