blob: e259c45beaf61d2b29971ff9a00e17158e4ffaff [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0"
Brad Bishop26bdd442019-08-16 17:08:17 -04004LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
Brad Bishop19323692019-04-05 15:28:33 -04005
Brad Bishop26bdd442019-08-16 17:08:17 -04006DEPENDS = "openssl"
Brad Bishop19323692019-04-05 15:28:33 -04007DEPENDS_append_class-target = " nodejs-native"
8
9inherit pkgconfig
10
11COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
12COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
13COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
14
15SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
16 file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
17 file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \
18 file://0004-Make-compatibility-with-gcc-4.8.patch \
19 file://0005-Link-atomic-library.patch \
20 file://0006-Use-target-ldflags.patch \
21 "
22SRC_URI_append_class-target = " \
23 file://0002-Using-native-torque.patch \
24 "
25
Brad Bishop26bdd442019-08-16 17:08:17 -040026SRC_URI[md5sum] = "fa70b942c5e3379ce96219fe90f50c8f"
27SRC_URI[sha256sum] = "6cbc17795e9259dce7a8f5fd5a2e46f9e6920fb48b7d9539c5b2faa5bb5db4d8"
Brad Bishop19323692019-04-05 15:28:33 -040028
29S = "${WORKDIR}/node-v${PV}"
30
31# v8 errors out if you have set CCACHE
32CCACHE = ""
33
34def map_nodejs_arch(a, d):
35 import re
36
37 if re.match('i.86$', a): return 'ia32'
38 elif re.match('x86_64$', a): return 'x64'
39 elif re.match('aarch64$', a): return 'arm64'
40 elif re.match('(powerpc64|ppc64le)$', a): return 'ppc64'
41 elif re.match('powerpc$', a): return 'ppc'
42 return a
43
44ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)} \
45 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-arm-fpu=neon', \
46 bb.utils.contains('TUNE_FEATURES', 'vfpv3d16', '--with-arm-fpu=vfpv3-d16', \
47 bb.utils.contains('TUNE_FEATURES', 'vfpv3', '--with-arm-fpu=vfpv3', \
48 '--with-arm-fpu=vfp', d), d), d)}"
49GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' "
50ARCHFLAGS ?= ""
51
Brad Bishop26bdd442019-08-16 17:08:17 -040052PACKAGECONFIG ??= "zlib icu"
53PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
54PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
55
Brad Bishop19323692019-04-05 15:28:33 -040056# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
57do_configure () {
58 rm -rf ${S}/deps/openssl
59 export LD="${CXX}"
60 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
61 # $TARGET_ARCH settings don't match --dest-cpu settings
Brad Bishop26bdd442019-08-16 17:08:17 -040062 ./configure --prefix=${prefix} --without-snapshot --shared-openssl \
Brad Bishop19323692019-04-05 15:28:33 -040063 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
64 --dest-os=linux \
Brad Bishop26bdd442019-08-16 17:08:17 -040065 ${ARCHFLAGS} \
66 ${PACKAGECONFIG_CONFARGS}
Brad Bishop19323692019-04-05 15:28:33 -040067}
68
69do_compile () {
70 export LD="${CXX}"
71 oe_runmake BUILDTYPE=Release
72}
73
74do_install () {
75 oe_runmake install DESTDIR=${D}
76}
77
78do_install_append_class-native() {
79 # use node from PATH instead of absolute path to sysroot
80 # node-v0.10.25/tools/install.py is using:
81 # shebang = os.path.join(node_prefix, 'bin/node')
82 # update_shebang(link_path, shebang)
83 # and node_prefix can be very long path to bindir in native sysroot and
84 # when it exceeds 128 character shebang limit it's stripped to incorrect path
85 # and npm fails to execute like in this case with 133 characters show in log.do_install:
86 # updating shebang of /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/work/x86_64-linux/nodejs-native/0.10.15-r0/image/home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/npm to /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/node
87 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
88 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
89 # npm-cli.js continues to use old shebang
90 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
91
92 # Install the native torque to provide it within sysroot for the target compilation
93 install -d ${D}${bindir}
94 install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque
95}
96
97do_install_append_class-target() {
98 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
99}
100
101PACKAGES =+ "${PN}-npm"
102FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx"
Brad Bishop26bdd442019-08-16 17:08:17 -0400103RDEPENDS_${PN}-npm = "bash python python-shell python-datetime python-subprocess python-textutils \
Brad Bishop19323692019-04-05 15:28:33 -0400104 python-compiler python-misc python-multiprocessing"
105
106PACKAGES =+ "${PN}-systemtap"
107FILES_${PN}-systemtap = "${datadir}/systemtap"
108
109
110BBCLASSEXTEND = "native"