blob: dba607c15d5fa5eed5b5a926dc6f726864e30ca3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS_append_libc-musl = " argp-standalone"
10
11inherit autotools
12
Brad Bishop26bdd442019-08-16 17:08:17 -040013# v0.9.3
14SRCREV = "e77780e7524c0a97f25313b205837191bbe9712a"
Brad Bishop19323692019-04-05 15:28:33 -040015SRC_URI = "git://github.com/namhyung/${BPN} \
16 "
17S = "${WORKDIR}/git"
18
19LDFLAGS_append_libc-musl = " -largp"
20
21def set_target_arch(d):
22 import re
23 arch = d.getVar('TARGET_ARCH')
24 if re.match(r'i.86', arch, re.I):
25 return 'i386'
26 elif re.match('armeb', arch, re.I):
27 return 'arm'
28 else:
29 return arch
30
31EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
32 with_elfutils=/use/libelf/from/sysroot"
33
34do_configure() {
35 ${S}/configure ${EXTRA_UFTRACE_OECONF}
36}
37
38FILES_SOLIBSDEV = ""
39FILES_${PN} += "${libdir}/*.so"
40
41COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
42
43# uftrace supports armv6 and above
44COMPATIBLE_HOST_armv4 = 'null'
45COMPATIBLE_HOST_armv5 = 'null'