blob: 0951ac076f0f1d185a8854a983d324801d33b6da [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Collects and summarises system performance statistics"
2DESCRIPTION = "collectd is a daemon which collects system performance statistics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files."
3LICENSE = "GPLv2 & MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1bd21f19f7f0c61a7be8ecacb0e28854"
5
6DEPENDS = "rrdtool curl libpcap libxml2 yajl libgcrypt libtool lvm2"
7
8SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
9 file://collectd.init \
10 file://collectd.service \
11 file://no-gcrypt-badpath.patch \
12 file://0001-conditionally-check-libvirt.patch \
13 file://0001-fix-to-build-with-glibc-2.25.patch \
14 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
15 file://0005-Disable-new-gcc8-warnings.patch \
16 file://0006-libcollectdclient-Fix-string-overflow-errors.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040017 file://0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch \
Brad Bishop19323692019-04-05 15:28:33 -040018 "
19SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6"
20SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da"
21
22inherit autotools pythonnative update-rc.d pkgconfig systemd
23
24SYSTEMD_SERVICE_${PN} = "collectd.service"
25
26# Floatingpoint layout, architecture dependent
27# 'nothing', 'endianflip' or 'intswap'
28FPLAYOUT ?= "--with-fp-layout=nothing"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[openjdk] = "--with-java=${STAGING_DIR_TARGET}${libdir}/jvm,--without-java,openjdk-7"
32PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp --with-libnetsnmp=no,net-snmp"
33PACKAGECONFIG[libmemcached] = "--with-libmemcached,--without-libmemcached,libmemcached"
34PACKAGECONFIG[iptables] = "--enable-iptables,--disable-iptables,iptables"
35PACKAGECONFIG[postgresql] = "--enable-postgresql --with-libpq=yes, \
36 --disable-postgresql --with-libpq=no,postgresql"
37PACKAGECONFIG[mysql] = "--enable-mysql --with-libmysql=yes, \
38 --disable-mysql --with-libmysql=no,mysql5"
39PACKAGECONFIG[dbi] = "--enable-dbi,--disable-dbi,libdbi"
40PACKAGECONFIG[modbus] = "--enable-modbus,--disable-modbus,libmodbus"
41PACKAGECONFIG[libowcapi] = "--with-libowcapi,--without-libowcapi,owfs"
42PACKAGECONFIG[sensors] = "--enable-sensors --with-libsensors=yes, \
43 --disable-sensors --with-libsensors=no,lmsensors"
44PACKAGECONFIG[amqp] = "--enable-amqp --with-librabbitmq=yes, \
45 --disable-amqp --with-librabbitmq=no,rabbitmq-c"
46# protobuf-c, libvirt that are currently only available in meta-virtualization layer
47PACKAGECONFIG[pinba] = "--enable-pinba,--disable-pinba,protobuf-c-native protobuf-c"
48PACKAGECONFIG[libvirt] = "--enable-virt,--disable-virt,libvirt"
49PACKAGECONFIG[libesmtp] = "--with-libesmtp,--without-libesmtp,libesmtp"
50PACKAGECONFIG[libmnl] = "--with-libmnl,--without-libmnl,libmnl"
51PACKAGECONFIG[libatasmart] = "--with-libatasmart,--without-libatasmart,libatasmart"
52PACKAGECONFIG[ldap] = "--enable-openldap --with-libldap,--disable-openldap --without-libldap, openldap"
53
54EXTRA_OECONF = " \
55 ${FPLAYOUT} \
56 --disable-perl --with-libperl=no --with-perl-bindings=no \
57 --with-libgcrypt=${STAGING_BINDIR_CROSS}/libgcrypt-config \
58 --disable-notify_desktop \
59"
60
61do_install_append() {
62 install -d ${D}${sysconfdir}/init.d
63 install -m 0755 ${WORKDIR}/collectd.init ${D}${sysconfdir}/init.d/collectd
64 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/collectd
65 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/collectd
66 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/collectd
67 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/collectd
68 install -Dm 0640 ${B}/src/collectd.conf ${D}${sysconfdir}/collectd.conf
69 # Fix configuration file to allow collectd to start up
70 sed -i 's!^#FQDNLookup[ \t]*true!FQDNLookup false!g' ${D}${sysconfdir}/collectd.conf
71
72 rmdir "${D}${localstatedir}/run"
73 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
74
75 # Install systemd unit files
76 install -d ${D}${systemd_unitdir}/system
77 install -m 0644 ${WORKDIR}/collectd.service ${D}${systemd_unitdir}/system
78 sed -i -e 's,@SBINDIR@,${sbindir},g' \
79 ${D}${systemd_unitdir}/system/collectd.service
80}
81
82CONFFILES_${PN} = "${sysconfdir}/collectd.conf"
83
84INITSCRIPT_NAME = "collectd"
85INITSCRIPT_PARAMS = "defaults"
86
87# threshold.so load.so are also provided by gegl
88# disk.so is also provided by libgphoto2-camlibs
89PRIVATE_LIBS = "threshold.so load.so disk.so"