blob: b7899a11b6937e960ede729ba5f863112260cc81 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Tools for taking the MD5 sum of ISO images"
2DESCRIPTION = "Tools for taking the MD5 sum of ISO images"
3
4DEPENDS = "popt python3 openssl curl popt-native"
Brad Bishop26bdd442019-08-16 17:08:17 -04005RDEPENDS_${BPN} = "openssl curl"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
9
10SRC_URI = "git://github.com/rhinstaller/isomd5sum.git;branch=master \
11 file://0001-tweak-install-prefix.patch \
12 file://0002-fix-parallel-error.patch \
13"
14
15S = "${WORKDIR}/git"
16inherit python3native
17
18EXTRA_OEMAKE += " \
19 DESTDIR='${D}' \
20 PYTHONINCLUDE='-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}' \
21 PYTHONSITEPACKAGES='${PYTHON_SITEPACKAGES_DIR}' \
22"
23
24do_install () {
25 oe_runmake install
26}
27
Brad Bishop26bdd442019-08-16 17:08:17 -040028PACKAGES += "${PYTHON_PN}-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Brad Bishop26bdd442019-08-16 17:08:17 -040030RPROVIDES_${BPN}-dbg += "${PYTHON_PN}-${BPN}-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Brad Bishop26bdd442019-08-16 17:08:17 -040032FILES_${PYTHON_PN}-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/pyisomd5sum.so"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34SRCREV = "7860901f726f5d92689cb67243cc7f981f21f74b"
35
36BBCLASSEXTEND = "native"