blob: c5fc928a7df70077096c61fca47b00de4c1407cf [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
6LICENSE = "LGPLv2+"
7SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
11inherit autotools python3native gobject-introspection
12
Brad Bishop26bdd442019-08-16 17:08:17 -040013SRCREV = "f6e4538485d0442b3674e182c01ffe5a0f258ad4"
Brad Bishop19323692019-04-05 15:28:33 -040014SRC_URI = " \
15 git://github.com/rhinstaller/libblockdev;branch=master \
16"
17
18S = "${WORKDIR}/git"
19
20FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
21
22PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm"
23PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
24PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
25PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
26PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
27PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
28PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
29PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
30PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
31PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
32PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
33PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
34PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
35PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
36PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
37PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
38PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
39PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
40PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
41
42export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"
43