blob: 3103748e406dc8a160d5459c5fa6e657264c61b8 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "The volume_key project provides a libvolume_key, a library for manipulating \
2storage volume encryption keys and storing them separately from volumes, and an \
3associated command-line tool, named volume_key."
4LICENSE = "GPLv2"
5SECTION = "devel/lib"
6
7HOMEPAGE = "https://pagure.io/volume_key"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "https://releases.pagure.org/volume_key/volume_key-${PV}.tar.xz \
12"
13SRC_URI[md5sum] = "200591290173c3ea71528411838f9080"
14SRC_URI[sha256sum] = "6ca3748fc1dad22c450bbf6601d4e706cb11c5e662d11bb4aeb473a9cd77309b"
15
16SRCNAME = "volume_key"
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit autotools python3native gettext
20
21DEPENDS += " \
22 util-linux \
23 glib-2.0 \
24 cryptsetup \
25 nss \
26 gpgme \
27 swig-native \
28"
29
30PACKAGECONFIG ??= "python3"
31PACKAGECONFIG[python] = "--with-python,--without-python,python,python"
32PACKAGECONFIG[python3] = "--with-python3,--without-python3,python3,python3"
33
Brad Bishop26bdd442019-08-16 17:08:17 -040034RDEPENDS_python3-${BPN} += "${PN}"
Brad Bishop19323692019-04-05 15:28:33 -040035
Brad Bishop26bdd442019-08-16 17:08:17 -040036PACKAGES += "python3-${BPN}"
37FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/*"