blob: b5d95d940b34cbe9d3ae8fc2b9f434758fe836fe [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Zstandard - Fast real-time compression algorithm"
2DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \
3real-time compression scenarios at zlib-level and better compression ratios. \
4It's backed by a very fast entropy stage, provided by Huff0 and FSE library."
5HOMEPAGE = "http://www.zstd.net/"
6SECTION = "console/utils"
7
8LICENSE = "BSD-3-Clause & GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \
10 file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
11
12SRC_URI = "git://github.com/facebook/zstd.git;nobranch=1"
13
14SRCREV = "ff304e9e65e7cde17a637eea190a874c26c48634"
15UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
16
17S = "${WORKDIR}/git"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4"
21PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz"
22PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib"
23
24# See programs/README.md for how to use this
25ZSTD_LEGACY_SUPPORT ??= "4"
26
27do_compile () {
28 oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT}
29}
30
31do_install () {
32 oe_runmake install 'DESTDIR=${D}'
33}
34
35BBCLASSEXTEND = "native nativesdk"