blob: c48a98183dbf36afb1ae9ffcc7163bb3b2338a30 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
5DEPENDS += "libunwind"
6
7SRCREV = "9608fa3bcf8020d35f59fbf70cd3cbe4b015b972"
8SRC_URI = "git://github.com/gperftools/gperftools \
9 file://0001-Support-Atomic-ops-on-clang.patch \
10 file://0001-fix-build-with-musl-libc.patch \
11 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
12 file://disable_libunwind_aarch64.patch \
13 file://sgidef.patch \
14 "
15
16inherit autotools
17
18S = "${WORKDIR}/git"
19
20# On mips, we have the following error.
21# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
22# Segmentation fault (core dumped)
23COMPATIBLE_HOST_mipsarch_libc-glibc = "null"
24# Disable thumb1
25# {standard input}: Assembler messages:
26# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
27# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
28ARM_INSTRUCTION_SET_armv5 = "arm"
Brad Bishop19323692019-04-05 15:28:33 -040029ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Brad Bishop26bdd442019-08-16 17:08:17 -040031# Ensure static libs are always enabled, as they seem to be not produced by
32# default at least on ARM.
33EXTRA_OECONF_append += " --enable-static"
34
35PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
36FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
37RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"
38