blob: 7e50edf7b24efb2c22b8e62cb29445f437eb1a8c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "file"
7
Brad Bishop26bdd442019-08-16 17:08:17 -04008SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI[md5sum] = "8ab5123535549195aff19e91b4e49f48"
10SRC_URI[sha256sum] = "9b9ccd7d0b11b0e179f1f58dc2caa3e0c62c8609e1e1dc7dcaadf941b67d923c"
11
12inherit autotools lib_package pkgconfig gettext
13
14CFLAGS += "-pthread -D_REENTRANT"
15
16EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
17
18PACKAGECONFIG ?= "curl https"
19PACKAGECONFIG_append_class-target = "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
21"
22PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
23PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
24PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
25
26do_compile_append() {
27 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
28}