blob: 3d26b9364bf54a01ce2280b256965107a0183d1a [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Lightweight and minimal dumb-terminal emulation program"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002SECTION = "console/utils"
3LICENSE = "GPLv2+"
Brad Bishop26bdd442019-08-16 17:08:17 -04004HOMEPAGE = "https://github.com/npat-efault/picocom"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000e4830620e310fe65c0eb69df9e8a"
6
Brad Bishop26bdd442019-08-16 17:08:17 -04007BASEPV = "3.1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008PV = "${BASEPV}+git${SRCPV}"
9
Brad Bishop26bdd442019-08-16 17:08:17 -040010SRCREV = "90385aabe2b51f39fa130627d46b377569f82d4a"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishop26bdd442019-08-16 17:08:17 -040012SRC_URI = "git://github.com/npat-efault/picocom \
13 file://0001-Fix-building-with-musl.patch \
14 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = "'CC=${CC}' 'LD=${CC}' 'VERSION=${BASEPV}' \
19 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' "
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 ${BPN} pcasc pcxm pcym pczm ${D}${bindir}/
24}
25