blob: 09cef44a850f2b35b08366a74b27e2adab74327a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Hash table and linked list for C structures"
2DESCRIPTION = " uthash-dev provides a hash table implementation using C preprocessor macros.\n\
3 This package also includes:\n\
4 * utlist.h provides linked list macros for C structures\n\
5 * utarray.h implements dynamic arrays using macros\n\
6 * utstring.h implements a basic dynamic string\n\
7"
8HOMEPAGE = "https://troydhanson.github.io/uthash/"
9SECTION = "base"
10LICENSE = "BSD-1-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=a2513f7d2291df840527b76b2a8f9718"
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRCREV = "8b214aefcb81df86a7e5e0d4fa20e59a6c18bc02"
Brad Bishop19323692019-04-05 15:28:33 -040013
14SRC_URI = "\
Brad Bishop15ae2502019-06-18 21:44:24 -040015 git://github.com/troydhanson/${BPN}.git \
Brad Bishop19323692019-04-05 15:28:33 -040016 file://run-ptest \
17"
Brad Bishop19323692019-04-05 15:28:33 -040018
Brad Bishop15ae2502019-06-18 21:44:24 -040019S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -040020
21inherit ptest
22
23do_compile[noexec] = "1"
24
25do_compile_ptest() {
26 oe_runmake -C tests tests_only TEST_TARGET=
27}
28
29do_install () {
30 install -dm755 ${D}${includedir}
31 install -m0644 src/*.h ${D}${includedir}
32}
33
34do_install_ptest() {
35 install -dm755 ${D}${PTEST_PATH}/tests
36 install -m0755 tests/test*[0-9] ${D}${PTEST_PATH}/tests
37 install -m0644 tests/test*[0-9].ans ${D}${PTEST_PATH}/tests
38 install -m0644 tests/test*[0-9].dat ${D}${PTEST_PATH}/tests
39}
40
41# The main package is empty and non-existent, so -dev
42# should not depend on it...
43RDEPENDS_${PN}-dev = ""
Brad Bishop26bdd442019-08-16 17:08:17 -040044RDEPENDS_${PN}-ptest_remove = "${PN}"
Brad Bishop19323692019-04-05 15:28:33 -040045
46BBCLASSEXTEND = "native"