blob: a8179744aea1dce17085e351a403aa1e47ce7544 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
9SRC_URI = "git://github.com/bats-core/bats-core.git \
10 "
11# v1.1.0
12SRCREV = "c706d1470dd1376687776bbe985ac22d09780327"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 # Just a bunch of bash scripts to install
18 ${S}/install.sh ${D}${prefix}
19}
20
21RDEPENDS_bats = "bash"