blob: 26c7c389d8a1a8d8880c7642f2894c16ddbdd3d1 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "LDAP Perl module"
2DESCRIPTION = "Net::LDAP is a collection of modules that implements \
3a LDAP services API for Perl programs. The module may be used to \
4search directories or perform maintenance functions such as adding, \
5deleting or modifying entries."
6
7SECTION = "libs"
8
9LICENSE = "Artistic-1.0|GPLv1+"
10LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "c4c1ae9299cd488e75c1b82904458bef"
15SRC_URI[sha256sum] = "09263ce6166e80c98d689d41d09995b813389fd069b784601f6dc57f8e2b4102"
16
17S = "${WORKDIR}/perl-ldap-${PV}"
18
19inherit cpan ptest-perl
20
21do_configure_prepend() {
22 perl -pi -e 's/auto_install_now.*//g' Makefile.PL
23}
24
25do_install_ptest() {
26 cp -r ${B}/data ${D}${PTEST_PATH}
27 chown -R root:root ${D}${PTEST_PATH}
28}
29
30RDEPENDS_${PN} += " \
31 libconvert-asn1-perl \
32 libio-socket-ssl-perl \
33 libauthen-sasl-perl \
34 perl-module-integer \
35"
36
37RDEPENDS_${PN}-ptest += " \
38 libxml-sax-base-perl \
39 libxml-sax-writer-perl \
40 perl-module-file-compare \
41 perl-module-perlio \
42 perl-module-test-more \
43"
44
45BBCLASSEXTEND = "native"