blob: f05103787082e99b422d217535a7ac4356fd89a8 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Sub::Uplevel - apparently run a function in a higher stack frame"
2DESCRIPTION = " Like Tcl's uplevel() function, but not quite so dangerous. \
3The idea is just to fool caller(). All the really naughty bits of Tcl's \
4uplevel() are avoided. \
5\
6THIS IS NOT THE SORT OF THING YOU WANT TO DO EVERYDAY \
7"
8
9SECTION = "libs"
10HOMEPAGE= "https://metacpan.org/release/Sub-Uplevel"
11
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=7f1207cd3108e4ade18448d81e6bcb6c"
14
15CPAN_PACKAGE = "Sub-Uplevel"
16CPAN_AUTHOR = "DAGOLDEN"
17
18SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "6c6a174861fd160e8d5871a86df00baf"
21SRC_URI[sha256sum] = "b4f3f63b80f680a421332d8851ddbe5a8e72fcaa74d5d1d98f3c8cc4a3ece293"
22
23S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
24
25inherit cpan ptest-perl
26
27RDEPENDS_${PN} += " \
28 perl-module-carp \
29 perl-module-constant \
30 perl-module-strict \
31 perl-module-warnings \
32"
33
34RDEPENDS_${PN}-ptest += " \
35 perl-module-cpan \
36 perl-module-exporter \
37 perl-module-extutils-makemaker \
38 perl-module-file-spec \
39 perl-module-lib \
40 perl-module-test-more \
41"
42
43BBCLASSEXTEND = "native nativesdk"