blob: 42f416346d409c49fd90a34820b1575e5f6848f4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Meta-oe ptest packagegroups"
2
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
7 packagegroup-meta-python \
8 packagegroup-meta-python3 \
9'
10
11RDEPENDS_packagegroup-meta-python = "\
12 packagegroup-meta-python-extended \
13 packagegroup-meta-python-connectivity \
14"
15
16RDEPENDS_packagegroup-meta-python3 = "\
17 packagegroup-meta-python3-extended \
18 packagegroup-meta-python3-connectivity \
19"
20
21RDEPENDS_packagegroup-meta-python = "\
22 python-psutil python-certifi python-flask python-pyroute2 python-pyopenssl python-pylint \
23 python-semver python-wrapt python-networkx python-behave python-dominate python-flask-user \
24 python-attrs python-humanize python-six python-flask-login python-zopeinterface python-sijax \
25 python-pyinotify python-stevedore python-pyjwt python-webdav python-twisted python-flask-sijax \
26 python-functools32 python-javaobj-py3 python-pygpgme python-future python-attr \
27 python-flask-xstatic python-m2crypto python-hyperlink python-imaging python-idna python-jinja2 \
28 python-can python-flask-bcrypt python-requests python-paste python-flask-script python-serpent \
29 python-cryptography python-pysmi python-xlrd python-appdirs python-jsonpatch python-bcrypt \
30 python-ndg-httpsclient python-pytest python-linecache2 python-visitor python-backports-abc \
31 python-setuptools-scm python-evdev python-pyjks python-jsonpointer python-cheetah python-gevent \
32 python-smbus python-sqlalchemy python-scrypt python-werkzeug python-anyjson python-pexpect \
33 python-robotframework-seriallibrary python-pyalsaaudio python-pytest-helpers-namespace \
34 python-alembic python-flask-pymongo python-slip-dbus python-pydbus python-automat python-rfc3987 \
35 python-tzlocal python-backports-ssl python-subprocess32 python-asn1crypto python-pybind11 \
Brad Bishop26bdd442019-08-16 17:08:17 -040036 python-ptyprocess python-babel python-passlib python-sdnotify \
Brad Bishop19323692019-04-05 15:28:33 -040037 python-lazy-object-proxy python-cryptography-vectors python-crcmod python-pyusb python-vobject \
38 python-webcolors python-pyparsing python-beautifulsoup4 python-cffi python-tornado-redis \
39 python-itsdangerous python-pyasn1-modules python-netaddr python-vcversioner \
40 python-sh python-greenlet python-paho-mqtt python-traceback2 python-gdata python-dbusmock \
41 python-whoosh python-lockfile python-isort python-wtforms python-feedparser python-flask-restful \
42 python-pysnmp python-flask-babel python-pytest-tempdir python-flask-nav python-pyzmq python-pyyaml \
Brad Bishop26bdd442019-08-16 17:08:17 -040043 python-protobuf python-pluggy python-jsonschema python-msgpack \
Brad Bishop19323692019-04-05 15:28:33 -040044 python-periphery python-pint python-pycryptodome python-yappi python-pycrypto python-pretend \
45 python-pyserial python-pyiface python-docutils python-grpcio-tools python-django-south \
46 python-backports-functools-lru-cache python-py python-click python-flask-migrate \
47 python-pyudev python-pystache python-blinker python-prompt-toolkit python-lxml \
48 python-unidiff python-inflection python-twofish python-prettytable python-webencodings \
49 python-mock python-pyexpect python-dnspython python-pysocks python-pynetlinux \
50 python-daemon python-djangorestframework python-typing python-monotonic python-sparts \
51 python-enum34 python-pyperclip python-flask-uploads python-pbr python-parse python-pyflakes \
52 python-pyhamcrest python-mako python-incremental python-tornado python-xstatic-font-awesome \
53 python-cmd2 python-strict-rfc3339 python-pycodestyle python-xstatic python-snakefood \
54 python-pybluez python-flask-navigation python-pyfirmata python-pymongo python-pysqlite \
55 python-progress python-flask-sqlalchemy python-pymisp python-pip python-ujson python-ply \
56 python-pep8 python-dateutil python-pycparser python-daemonize python-astroid python-pyrex \
57 python-markupsafe python-pytest-runner python-grpcio python-mccabe python-pytz python-selectors34 \
58 python-cython python-chardet python-editor python-flask-bootstrap python-html5lib \
59 python-singledispatch python-redis python-flask-mail python-funcsigs python-snimpy python-pyasn1 \
Brad Bishop26bdd442019-08-16 17:08:17 -040060 python-decorator python-urllib3 python-feedformatter python-iso8601 \
Brad Bishop19323692019-04-05 15:28:33 -040061 python-numeric python-robotframework python-django python-simplejson python-wcwidth \
62 python-configparser python-epydoc python-intervals python-speaklater \
63 python-aws-iot-device-sdk-python python-constantly python-bitarray python-flask-wtf \
64 python-parse-type python-ipaddress python-dbus \
65 ${@bb.utils.contains("DISTRO_FEATURES", "pam", "python-pam pamela", "", d)} \
66 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python-systemd", "", d)} \
67"
68
69RDEPENDS_packagegroup-meta-python3 = "\
70 python3-pyserial python3-gevent python3-alembic python3-robotframework-seriallibrary \
71 python3-rfc3987 python3-xlrd python3-bandit python3-constantly python3-inflection \
72 python3-javaobj-py3 python3-sh python3-pycrypto python3-pyasn1 python3-pydbus python3-wtforms \
73 python3-pybluez python3-babel python3-parse-type python3-bitarray python3-django-south \
74 python3-pyusb python3-prctl python3-jinja2 python3-werkzeug python3-pyjks python3-requests-ftp \
75 python3-behave python3-pyparsing python3-pyyaml python3-tzlocal python3-pretend python3-stevedore \
76 python3-sijax python3-langtable python3-requests-file python3-crcmod python3-robotframework \
77 python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \
78 python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \
79 python3-flask-script python3-cassandra-driver python3-cython python3-ujson python3-aws-iot-device-sdk-python \
80 python3-pytest-runner python3-pyiface python3-flask-login python3-markupsafe python3-setuptools-scm \
81 python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \
82 python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \
83 python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \
84 python3-flask-bootstrap python3-pyudev python3-decorator python3-pybind11 python3-pluggy python3-redis \
85 python3-pycryptodome python3-passlib python3-dominate python3-ply python3-ntplib python3-serpent python3-wrapt \
86 python3-attrs python3-appdirs python3-isort python3-evdev python3-incremental python3-click python3-flask-nav \
87 python3-webcolors python3-dateutil python3-blinker python3-hyperlink python3-lxml python3-pylint \
88 python3-flask-migrate python3-pytest-tempdir python3-flask-restful python3-feedformatter \
89 python3-pyasn1-modules python3-scapy python3-html5lib python3-dnspython python3-automat \
90 python3-itsdangerous python3-pandas python3-pyfirmata python3-protobuf \
91 python3-flask-babel python3-anyjson python3-flask-xstatic python3-multidict python3-prompt-toolkit \
92 python3-periphery python3-greenlet python3-pytz python3-pyexpect python3-zopeinterface \
93 python3-bcrypt python3-xstatic-font-awesome python3-m2crypto python3-parse python3-attr \
94 python3-beautifulsoup4 python3-pycodestyle python3-oauthlib python3-grpcio python3-scrypt \
95 python3-pyjwt python3-astroid python3-flask-pymongo python3-wcwidth python3-lazy-object-proxy \
96 python3-websockets python3-pyzmq python3-pytest python3-chardet python3-vcversioner python3-whoosh \
97 python3-pymisp python3-certifi python3-psutil python3-flask-sqlalchemy python3-humanize \
98 python3-grpcio-tools python3-configparser python3-strict-rfc3339 python3-paho-mqtt \
99 python3-pytest-helpers-namespace python3-flask python3-flask-wtf python3-visitor python3-pynetlinux \
100 python3-requests python3-cryptography-vectors python3-spidev python3-pid python3-pymongo \
101 python3-future python3-django python3-unidiff python3-webencodings python3-can python3-pyalsaaudio \
102 python3-flask-sijax python3-cryptography python3-twisted python3-netaddr python3-pycparser \
103 python3-flask-uploads python3-pysocks python3-cffi python3-editor python3-ptyprocess \
104 python3-pyopenssl python3-ordered-set python3-simplejson python3-py \
105 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
106"
107
108RDEPENDS_packagegroup-meta-python-extended = "\
109 python-pyephem \
110 python-cson \
111 python-pywbem \
112 python-pyparted \
113"
114
115RDEPENDS_packagegroup-meta-python3-extended = "\
116 python3-pykickstart \
117 python3-meh \
118 python3-blivet \
119 python3-pywbem \
120 python3-pyparted \
121 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
122"
123
124RDEPENDS_packagegroup-meta-python-connectivity = "\
125 python-pyro4 \
126 python-pytun \
127 python-mprpc \
128 python-thrift \
129 python-txws \
130 python-pyconnman \
131 python-gsocketpool \
132"
133
134RDEPENDS_packagegroup-meta-python3-connectivity = "\
135 python3-pytun \
136 python3-mprpc \
137 python3-pyconnman \
138 python3-gsocketpool \
139"
140
141RDEPENDS_packagegroup-meta-python-ptest = "\
142 python-pygpgme \
143 python-cryptography \
144 "
145
146RDEPENDS_packagegroup-meta-python3-ptest = "\
147 python3-cryptography \
148 "
149
150EXCLUDE_FROM_WORLD = "1"