blob: 45492daa6e42051fd445d911dec54df3dc8278e7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The ssl.match_hostname() function from Python 3.4"
2DESCRIPTION = "The Secure Sockets layer is only actually secure if you check the hostname in the \
3certificate returned by the server to which you are connecting, and verify that it matches to hostname \
4that you are trying to reach. But the matching logic, defined in RFC2818, can be a bit tricky to implement \
5on your own. So the ssl package in the Standard Library of Python 3.2 and greater now includes a \
6match_hostname() function for performing this check instead of requiring every application to \
7implement the check separately. This backport brings match_hostname() to users of earlier versions of Python"
8
9LICENSE = "GPLv2"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010LIC_FILES_CHKSUM = "file://PKG-INFO;md5=95a5ee8fd779fbeca8b4cbca64433c87"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Patrick Williamsddad1a12017-02-23 20:36:32 -060012SRC_URI[md5sum] = "c03fc5e2c7b3da46b81acf5cbacfe1e6"
13SRC_URI[sha256sum] = "502ad98707319f4a51fa2ca1c677bd659008d27ded9f6380c79e8932e38dcdf2"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
15PYPI_PACKAGE = "backports.ssl_match_hostname"
16inherit pypi setuptools
Patrick Williamsddad1a12017-02-23 20:36:32 -060017
18RDEPENDS_${PN} += "${PYTHON_PN}-pkgutil"