blob: fdd50d4350c55e31b3b67be53b796fb9a408aed9 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001DESCRIPTION = "Application library for the Xfce desktop environment"
Brad Bishopc342db32019-05-15 21:57:59 -04002SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Brad Bishop26bdd442019-08-16 17:08:17 -04005DEPENDS = "gtk+3 libxfce4ui virtual/libx11 liburi-perl-native cairo"
Brad Bishopc342db32019-05-15 21:57:59 -04006DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
7
8inherit xfce pythonnative perlnative gtk-doc distro_features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11REQUIRED_DISTRO_FEATURES_class-native = ""
12
13# SRC_URI must follow inherited one
14SRC_URI += " \
15 file://exo-no-tests-0.8.patch \
16 file://configure.patch \
17"
18
19SRC_URI_append_class-native = " \
20 file://reduce-build-to-exo-csource-only.patch \
21"
22
Brad Bishop26bdd442019-08-16 17:08:17 -040023SRC_URI[md5sum] = "e618ce760a12ac7427a48a44c69f3d31"
24SRC_URI[sha256sum] = "3400a2e64aa41ede25bedaca4909bde7ea4f8698d9598d1b80f02a40ac89fcde"
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG_class-target ??= "gtk"
28PACKAGECONFIG[gtk] = "--enable-gtk2,--disable-gtk2,gtk+"
Brad Bishopc342db32019-05-15 21:57:59 -040029
30PACKAGES =+ "exo-csource"
31
32# Note: python bindings did not work in oe-dev and are about to be moved to
33# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
34FILES_${PN} += " \
35 ${datadir}/xfce4/ \
36 ${libdir}/xfce4/exo* \
37"
38
39FILES_exo-csource += "${bindir}/exo-csource"
40
41BBCLASSEXTEND = "native"