blob: 749c3fea48418e6ecfcb1b208650d8008829d5fa [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
Brad Bishop26bdd442019-08-16 17:08:17 -04005DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native"
Brad Bishop19323692019-04-05 15:28:33 -04006
Brad Bishop26bdd442019-08-16 17:08:17 -04007inherit xfce gtk-doc gobject-introspection distro_features_check remove-libtool
Brad Bishop19323692019-04-05 15:28:33 -04008
9REQUIRED_DISTRO_FEATURES = "x11"
10
Brad Bishop26bdd442019-08-16 17:08:17 -040011SRC_URI[md5sum] = "940e8b430e28093a2e56e390055bcd51"
12SRC_URI[sha256sum] = "d5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4"
Brad Bishop19323692019-04-05 15:28:33 -040013SRC_URI += " \
14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040015 file://0001-use-lxdm-to-replace-dm-tool.patch \
Brad Bishop19323692019-04-05 15:28:33 -040016"
17
18python populate_packages_prepend() {
19 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
20 plugin_name = d.expand('${PN}-plugin-%s')
21 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
22 '${PN} plugin for %s', extra_depends='', prepend=True,
23 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
24 '${sysconfdir}/xdg/xfce/panel/%s-*',
25 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
26 '${bindir}/*%s*'])
27}
28
29PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
30
31PACKAGES =+ "${PN}-gtk3"
32
33FILES_${PN} += "${libdir}/xfce4/panel/migrate \
34 ${libdir}/xfce4/panel/wrapper-1.0"
35
36FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
37
38FILES_${PN}-gtk3 = " \
39 ${libdir}/libxfce4panel-2.0${SOLIBS} \
40 ${libdir}/xfce4/panel/wrapper-2.0 \
41"