blob: 284a29ba25a87193cb3bf0e7c771d5b8bffb73a4 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Power manager for the Xfce desktop environment"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
3SECTION = "x11"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8inherit xfce distro_features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11
Brad Bishop26bdd442019-08-16 17:08:17 -040012DEPENDS += "libnotify libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver"
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
Brad Bishop26bdd442019-08-16 17:08:17 -040014SRC_URI[md5sum] = "709efbc2de9ed84b4831847ff70bcd7f"
15SRC_URI[sha256sum] = "10adb67899b181ca5fc577fc9bb7a698fb94e42073585f7e2be642c7db127a74"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17EXTRA_OECONF = " \
18 --enable-network-manager \
19 --enable-panel-plugins \
20"
21
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
23PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit"
Brad Bishop316dfdd2018-06-25 12:45:53 -040024
25PACKAGES += "xfce4-powermanager-plugin"
26
27FILES_${PN} += " \
28 ${datadir}/polkit-1 \
Brad Bishop15ae2502019-06-18 21:44:24 -040029 ${datadir}/metainfo \
Brad Bishop316dfdd2018-06-25 12:45:53 -040030"
31
32FILES_xfce4-powermanager-plugin = " \
33 ${libdir}/xfce4 \
34 ${datadir}/xfce4 \
35"
36
37RDEPENDS_xfce4-powermanager-plugin = "${PN}"
38RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
39
40# xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
41RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
42RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
43RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin"