blob: 77b45a7c9b99c371f0f2235ddc745497002b34c8 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001DESCRIPTION = "Xfce4 Window Manager"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
Brad Bishop26bdd442019-08-16 17:08:17 -04005DEPENDS = "virtual/libx11 libxfce4ui libwnck3 libxinerama exo-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006
7inherit xfce update-alternatives distro_features_check
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
Brad Bishop26bdd442019-08-16 17:08:17 -040011SRC_URI += "file://0001-Revert-compositor-Revert-to-GLX-as-default-vblank-me.patch"
12SRC_URI[md5sum] = "c33847836958d540e3ecd0a27f131c0f"
13SRC_URI[sha256sum] = "b4182bf8dc63d092f120a51fcae0eb54b9bd4aa4f8486f47e5a65a108322b615"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15PACKAGECONFIG ?= " \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'epoxy', '', d)} \
17 xpresent \
18 startup-notification \
19"
20
21PACKAGECONFIG[epoxy] = "--enable-epoxy,--disable-epoxy,libepoxy"
22PACKAGECONFIG[xpresent] = "--enable-xpresent,--disable-xpresent,libxpresent"
23PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
24
25python populate_packages_prepend () {
26 themedir = d.expand('${datadir}/themes')
27 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
28}
29
30PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
31
32ALTERNATIVE_${PN} = "x-window-manager"
33ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
34ALTERNATIVE_PRIORITY[x-window-manager] = "30"
35
36RDEPENDS_${PN} = "xfwm4-theme-default"
37FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
38 ${datadir}/xfwm4/defaults \
39"