blob: 9af4442da17901cd8be5441efbf13cb8c1c6b918 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Host API C++ bindings"
2DESCRIPTION = "OpenCL compute API headers C++ bindings from Khronos Group"
3LICENSE = "Khronos"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e4a01f0c56b39419aa287361a82df00"
5SECTION = "base"
6
7SRC_URI = "git://github.com/KhronosGroup/OpenCL-CLHPP.git;protocol=https"
8
9PV = "2.0.10+git${SRCPV}"
10SRCREV = "acd6972bc65845aa28bd9f670dec84cbf8b760f3"
11
12S = "${WORKDIR}/git"
13
14do_configure () {
15:
16}
17
18# Only cl2.hpp is necessary.
19# Base on the repo, Directly input_cl2.hpp copied as cl2.hpp
20do_compile () {
21:
22}
23
24do_install () {
25 install -d ${D}${includedir}/CL/
26 install -m 0644 ${S}/input_cl2.hpp ${D}${includedir}/CL/cl2.hpp
27}
28
29ALLOW_EMPTY_${PN} = "1"