Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | require rust-target.inc |
2 | require rust-source.inc | ||||
3 | require rust-snapshot.inc | ||||
4 | |||||
5 | INSANE_SKIP:${PN}:class-native = "already-stripped" | ||||
6 | |||||
7 | do_compile () { | ||||
8 | rust_runx build --stage 2 | ||||
9 | } | ||||
10 | |||||
11 | rust_do_install() { | ||||
12 | rust_runx install | ||||
13 | } | ||||
14 | |||||
15 | python () { | ||||
16 | pn = d.getVar('PN') | ||||
17 | |||||
18 | if not pn.endswith("-native"): | ||||
19 | raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.") | ||||
20 | } | ||||
21 |