blob: 797db738f47e4f6a18b1d1b06f8574a0840e4b18 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 "
10
Brad Bishopf3f93bb2019-10-16 14:33:32 -040011SRCREV = "bc67f19ed09593e3886ebeee2391e9d51cc3439f"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13S = "${WORKDIR}/git"
14
Brad Bishopf3f93bb2019-10-16 14:33:32 -040015DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
Brad Bishopc342db32019-05-15 21:57:59 -040016DEPENDS_append_class-native = " file-replacement-native"
17
18inherit cmake pkgconfig bash-completion distutils3-base
19
Brad Bishopf3f93bb2019-10-16 14:33:32 -040020EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
Brad Bishopc342db32019-05-15 21:57:59 -040021
22BBCLASSEXTEND = "native nativesdk"
23
24# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
25do_install_append_class-native() {
26 create_wrapper ${D}/${bindir}/createrepo_c \
27 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
28}
29
30do_install_append_class-nativesdk() {
31 create_wrapper ${D}/${bindir}/createrepo_c \
32 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
33 rm -rf ${D}/etc
34}