blob: 9dd753db4fc62c0d78c632add4b976a9f4a89275 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
Brad Bishop316dfdd2018-06-25 12:45:53 -040011PYPI_PACKAGE = "GitPython"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012
Brad Bishop08902b02019-08-20 09:16:51 -040013inherit pypi setuptools3
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014
Brad Bishop79641f22019-09-10 07:20:22 -040015SRC_URI[md5sum] = "ccec14a5c9f18702406122983d80032c"
16SRC_URI[sha256sum] = "d2f4945f8260f6981d724f5957bc076398ada55cb5d25aaee10108bcdc894100"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017
Brad Bishop08902b02019-08-20 09:16:51 -040018DEPENDS += " ${PYTHON_PN}-gitdb"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060019
Brad Bishop316dfdd2018-06-25 12:45:53 -040020RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-gitdb \
23 ${PYTHON_PN}-io \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-math \
26 ${PYTHON_PN}-netclient \
27 ${PYTHON_PN}-stringold \
28 ${PYTHON_PN}-unittest \
29 ${PYTHON_PN}-unixadmin \
30 git \
31"
Brad Bishop08902b02019-08-20 09:16:51 -040032
Brad Bishop19323692019-04-05 15:28:33 -040033BBCLASSEXTEND = "native nativesdk"