blob: 20ce69872932fa565f5d93964a093c4806fcb30b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
Brad Bishopf3f93bb2019-10-16 14:33:32 -04005LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04006LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9RDEPENDS_${PN} = "lighttpd-module-dirlisting \
10 lighttpd-module-indexfile \
11 lighttpd-module-staticfile"
12RRECOMMENDS_${PN} = "lighttpd-module-access \
13 lighttpd-module-accesslog"
14
15SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
16 file://index.html.lighttpd \
17 file://lighttpd.conf \
18 file://lighttpd \
19 file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \
20 "
21
Brad Bishopf3fd2882019-06-21 08:06:37 -040022SRC_URI[md5sum] = "7abc776243c811e9872f73ab38b7f8b5"
23SRC_URI[sha256sum] = "cf14cce2254a96d8fcb6d3181e1a3c29a8f832531c3e86ff6f2524ecda9a8721"
Brad Bishop19323692019-04-05 15:28:33 -040024
25PACKAGECONFIG ??= "openssl pcre zlib \
26 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
28"
29
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
31PACKAGECONFIG[mmap] = "--enable-mmap,--disable-mmap"
32PACKAGECONFIG[libev] = "--with-libev,--without-libev,libev"
33PACKAGECONFIG[mysql] = "--with-mysql,--without-mysql,mariadb"
34PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
35PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
36PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
37PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
38PACKAGECONFIG[krb5] = "--with-krb5,--without-krb5,krb5"
39PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,libpcre"
40PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
41PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
Brad Bishop19323692019-04-05 15:28:33 -040042PACKAGECONFIG[webdav-props] = "--with-webdav-props,--without-webdav-props,libxml2 sqlite3"
43PACKAGECONFIG[webdav-locks] = "--with-webdav-locks,--without-webdav-locks,util-linux"
44PACKAGECONFIG[gdbm] = "--with-gdbm,--without-gdbm,gdbm"
45PACKAGECONFIG[memcache] = "--with-memcached,--without-memcached,libmemcached"
Brad Bishop79641f22019-09-10 07:20:22 -040046PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
Brad Bishop19323692019-04-05 15:28:33 -040047
Brad Bishop00e122a2019-10-05 11:10:57 -040048EXTRA_OECONF += "--enable-lfs --without-fam"
Brad Bishop19323692019-04-05 15:28:33 -040049
50inherit autotools pkgconfig update-rc.d gettext systemd
51
52INITSCRIPT_NAME = "lighttpd"
53INITSCRIPT_PARAMS = "defaults 70"
54
55SYSTEMD_SERVICE_${PN} = "lighttpd.service"
56
57do_install_append() {
58 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
59 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
60 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}/lighttpd
61 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
62
63 install -d ${D}${systemd_unitdir}/system
64 install -m 0644 ${S}/doc/systemd/lighttpd.service ${D}${systemd_unitdir}/system
65 sed -i -e 's,@SBINDIR@,${sbindir},g' \
66 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
67 -e 's,@BASE_BINDIR@,${base_bindir},g' \
68 ${D}${systemd_unitdir}/system/lighttpd.service
69 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
70 ln -sf ${localstatedir}/log ${D}/www/logs
71 ln -sf ${localstatedir}/tmp ${D}/www/var
72}
73
74FILES_${PN} += "${sysconfdir} /www"
75
76CONFFILES_${PN} = "${sysconfdir}/lighttpd/lighttpd.conf"
77
78PACKAGES_DYNAMIC += "^lighttpd-module-.*"
79
80python populate_packages_prepend () {
81 lighttpd_libdir = d.expand('${libdir}')
82 do_split_packages(d, lighttpd_libdir, r'^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
83}