blob: acb9938ff39d2bf6ed207f785eb52821c89523cd [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001# This recipe tracks the 'bleeding edge' linux-xlnx repository.
2# Since this tree is frequently updated, AUTOREV is used to track its contents.
3#
4# To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-xlnx-dev"
5
6KBRANCH ?= "master"
7
8# Use the SRCREV for the last tagged revision of linux-xlnx.
9SRCREV ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-xlnx-dev", "${AUTOREV}", "84fb0cc65aae5970471cbc54b0c89009b9b904af", d)}'
10
11# skip version sanity, because the version moves with AUTOREV
12KERNEL_VERSION_SANITY_SKIP = "1"
13
14LINUX_VERSION ?= "4.9+"
15LINUX_VERSION_EXTENSION ?= "-xilinx-dev"
16
17include linux-xlnx.inc
18