blob: 5479007d9212513445a088332abe6ff684f99961 [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "LibTomCrypt is a public domain open source cryptographic toolkit"
2HOMEPAGE = "https://www.libtom.net/LibTomCrypt"
3SECTION = "libs"
Patrick Williams2a254922023-08-11 09:48:11 -05004# Unlicense isn't very accurate for this revision, it was WTFPL in 0.18.0-rc1:
5# https://github.com/libtom/libtomcrypt/commit/77e31fb6a980212e90b9a50f116dc5a7bd91e527
6# then updated to dual license PD and WTFPL also in 0.18.0-rc1:
7# https://github.com/libtom/libtomcrypt/commit/412b2ee1fccc3a0df58f93f372c90d6d0f93bfc9
8# and then updated again to Unlicense after the 0.18.2 tag (it's only in develop branch):
9# https://github.com/libtom/libtomcrypt/commit/3630bee6fc0f73dd9c7923fd43f8ae15a2c0fb70
10# but keep using Unlicense to avoid triggering people with WTFPL license:
11# https://groups.google.com/g/libtom/c/17Z7xkECULM
12# and this comment can be removed next time libtomcrypt is updated
Andrew Geissler78b72792022-06-14 06:47:25 -050013LICENSE = "Unlicense"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
15
Patrick Williams2a254922023-08-11 09:48:11 -050016DEPENDS = "libtool-cross"
Andrew Geissler78b72792022-06-14 06:47:25 -050017
Patrick Williams2a254922023-08-11 09:48:11 -050018SRC_URI = "git://github.com/libtom/libtomcrypt.git;protocol=https;branch=master \
19 file://CVE-2019-17362.patch \
20"
Andrew Geissler78b72792022-06-14 06:47:25 -050021
22SRCREV = "7e7eb695d581782f04b24dc444cbfde86af59853"
23
24S = "${WORKDIR}/git"
25
Patrick Williams2a254922023-08-11 09:48:11 -050026inherit pkgconfig
27
28PACKAGECONFIG ??= "ltm"
29PACKAGECONFIG[ltm] = ",,libtommath"
30
31CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'ltm', '-DUSE_LTM -DLTM_DESC', '', d)}"
32
33EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' 'CFLAGS=${CFLAGS}'"
34
Andrew Geissler78b72792022-06-14 06:47:25 -050035do_compile() {
36 oe_runmake -f makefile.shared
37}
38
39do_install() {
Patrick Williams2a254922023-08-11 09:48:11 -050040 oe_runmake -f makefile.shared install
Andrew Geissler78b72792022-06-14 06:47:25 -050041}