blob: aedd78a03aa36928df0daad5ef04889fc1c65966 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# Copyright (C) 2012 Linux Foundation
2# Author: Richard Purdie
3# Some code and influence taken from srctree.bbclass:
4# Copyright (C) 2009 Chris Larson <clarson@kergoth.com>
5#
6# SPDX-License-Identifier: MIT
7#
8# externalsrc.bbclass enables use of an existing source tree, usually external to
9# the build system to build a piece of software rather than the usual fetch/unpack/patch
10# process.
11#
12# To use, add externalsrc to the global inherit and set EXTERNALSRC to point at the
13# directory you want to use containing the sources e.g. from local.conf for a recipe
14# called "myrecipe" you would do:
15#
16# INHERIT += "externalsrc"
17# EXTERNALSRC:pn-myrecipe = "/path/to/my/source/tree"
18#
19# In order to make this class work for both target and native versions (or with
20# multilibs/cross or other BBCLASSEXTEND variants), B is set to point to a separate
21# directory under the work directory (split source and build directories). This is
22# the default, but the build directory can be set to the source directory if
23# circumstances dictate by setting EXTERNALSRC_BUILD to the same value, e.g.:
24#
25# EXTERNALSRC_BUILD:pn-myrecipe = "/path/to/my/source/tree"
26#
27
28SRCTREECOVEREDTASKS ?= "do_patch do_unpack do_fetch"
29EXTERNALSRC_SYMLINKS ?= "oe-workdir:${WORKDIR} oe-logs:${T}"
30
31python () {
32 externalsrc = d.getVar('EXTERNALSRC')
33 externalsrcbuild = d.getVar('EXTERNALSRC_BUILD')
34
35 if externalsrc and not externalsrc.startswith("/"):
36 bb.error("EXTERNALSRC must be an absolute path")
37 if externalsrcbuild and not externalsrcbuild.startswith("/"):
38 bb.error("EXTERNALSRC_BUILD must be an absolute path")
39
40 # If this is the base recipe and EXTERNALSRC is set for it or any of its
41 # derivatives, then enable BB_DONT_CACHE to force the recipe to always be
42 # re-parsed so that the file-checksums function for do_compile is run every
43 # time.
44 bpn = d.getVar('BPN')
45 classextend = (d.getVar('BBCLASSEXTEND') or '').split()
46 if bpn == d.getVar('PN') or not classextend:
47 if (externalsrc or
48 ('native' in classextend and
49 d.getVar('EXTERNALSRC:pn-%s-native' % bpn)) or
50 ('nativesdk' in classextend and
51 d.getVar('EXTERNALSRC:pn-nativesdk-%s' % bpn)) or
52 ('cross' in classextend and
53 d.getVar('EXTERNALSRC:pn-%s-cross' % bpn))):
54 d.setVar('BB_DONT_CACHE', '1')
55
56 if externalsrc:
57 import oe.recipeutils
58 import oe.path
59
60 d.setVar('S', externalsrc)
61 if externalsrcbuild:
62 d.setVar('B', externalsrcbuild)
63 else:
Patrick Williams2390b1b2022-11-03 13:47:49 -050064 d.setVar('B', '${WORKDIR}/${BPN}-${PV}')
Patrick Williams92b42cb2022-09-03 06:53:57 -050065
66 local_srcuri = []
67 fetch = bb.fetch2.Fetch((d.getVar('SRC_URI') or '').split(), d)
68 for url in fetch.urls:
69 url_data = fetch.ud[url]
70 parm = url_data.parm
Patrick Williams8e7b46e2023-05-01 14:19:06 -050071 if url_data.type in ['file', 'npmsw', 'crate'] or parm.get('type') in ['kmeta', 'git-dependency']:
Patrick Williams92b42cb2022-09-03 06:53:57 -050072 local_srcuri.append(url)
73
74 d.setVar('SRC_URI', ' '.join(local_srcuri))
75
76 # Dummy value because the default function can't be called with blank SRC_URI
77 d.setVar('SRCPV', '999')
Patrick Williams2a254922023-08-11 09:48:11 -050078 # sstate is never going to work for external source trees, disable it
79 d.setVar('SSTATE_SKIP_CREATION', '1')
Patrick Williams92b42cb2022-09-03 06:53:57 -050080
81 if d.getVar('CONFIGUREOPT_DEPTRACK') == '--disable-dependency-tracking':
82 d.setVar('CONFIGUREOPT_DEPTRACK', '')
83
84 tasks = filter(lambda k: d.getVarFlag(k, "task"), d.keys())
85
86 for task in tasks:
Patrick Williams2a254922023-08-11 09:48:11 -050087 if os.path.realpath(d.getVar('S')) == os.path.realpath(d.getVar('B')):
Patrick Williams92b42cb2022-09-03 06:53:57 -050088 # Since configure will likely touch ${S}, ensure only we lock so one task has access at a time
89 d.appendVarFlag(task, "lockfiles", " ${S}/singletask.lock")
90
Andrew Geissler87f5cff2022-09-30 13:13:31 -050091 for v in d.keys():
92 cleandirs = d.getVarFlag(v, "cleandirs", False)
93 if cleandirs:
Patrick Williams92b42cb2022-09-03 06:53:57 -050094 # We do not want our source to be wiped out, ever (kernel.bbclass does this for do_clean)
Andrew Geissler87f5cff2022-09-30 13:13:31 -050095 cleandirs = oe.recipeutils.split_var_value(cleandirs)
Patrick Williams92b42cb2022-09-03 06:53:57 -050096 setvalue = False
97 for cleandir in cleandirs[:]:
98 if oe.path.is_path_parent(externalsrc, d.expand(cleandir)):
99 cleandirs.remove(cleandir)
100 setvalue = True
101 if setvalue:
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500102 d.setVarFlag(v, 'cleandirs', ' '.join(cleandirs))
Patrick Williams92b42cb2022-09-03 06:53:57 -0500103
104 fetch_tasks = ['do_fetch', 'do_unpack']
105 # If we deltask do_patch, there's no dependency to ensure do_unpack gets run, so add one
106 # Note that we cannot use d.appendVarFlag() here because deps is expected to be a list object, not a string
107 d.setVarFlag('do_configure', 'deps', (d.getVarFlag('do_configure', 'deps', False) or []) + ['do_unpack'])
108
109 for task in d.getVar("SRCTREECOVEREDTASKS").split():
110 if local_srcuri and task in fetch_tasks:
111 continue
112 bb.build.deltask(task, d)
113 if task == 'do_unpack':
114 # The reproducible build create_source_date_epoch_stamp function must
115 # be run after the source is available and before the
116 # do_deploy_source_date_epoch task. In the normal case, it's attached
117 # to do_unpack as a postfuncs, but since we removed do_unpack (above)
118 # we need to move the function elsewhere. The easiest thing to do is
119 # move it into the prefuncs of the do_deploy_source_date_epoch task.
120 # This is safe, as externalsrc runs with the source already unpacked.
121 d.prependVarFlag('do_deploy_source_date_epoch', 'prefuncs', 'create_source_date_epoch_stamp ')
122
123 d.prependVarFlag('do_compile', 'prefuncs', "externalsrc_compile_prefunc ")
124 d.prependVarFlag('do_configure', 'prefuncs', "externalsrc_configure_prefunc ")
125
126 d.setVarFlag('do_compile', 'file-checksums', '${@srctree_hash_files(d)}')
127 d.setVarFlag('do_configure', 'file-checksums', '${@srctree_configure_hash_files(d)}')
128
129 # We don't want the workdir to go away
130 d.appendVar('RM_WORK_EXCLUDE', ' ' + d.getVar('PN'))
131
132 bb.build.addtask('do_buildclean',
133 'do_clean' if d.getVar('S') == d.getVar('B') else None,
134 None, d)
135
136 # If B=S the same builddir is used even for different architectures.
137 # Thus, use a shared CONFIGURESTAMPFILE and STAMP directory so that
138 # change of do_configure task hash is correctly detected and stamps are
139 # invalidated if e.g. MACHINE changes.
140 if d.getVar('S') == d.getVar('B'):
141 configstamp = '${TMPDIR}/work-shared/${PN}/${EXTENDPE}${PV}-${PR}/configure.sstate'
142 d.setVar('CONFIGURESTAMPFILE', configstamp)
143 d.setVar('STAMP', '${STAMPS_DIR}/work-shared/${PN}/${EXTENDPE}${PV}-${PR}')
144 d.setVar('STAMPCLEAN', '${STAMPS_DIR}/work-shared/${PN}/*-*')
145}
146
147python externalsrc_configure_prefunc() {
148 s_dir = d.getVar('S')
149 # Create desired symlinks
150 symlinks = (d.getVar('EXTERNALSRC_SYMLINKS') or '').split()
151 newlinks = []
152 for symlink in symlinks:
153 symsplit = symlink.split(':', 1)
154 lnkfile = os.path.join(s_dir, symsplit[0])
155 target = d.expand(symsplit[1])
156 if len(symsplit) > 1:
157 if os.path.islink(lnkfile):
158 # Link already exists, leave it if it points to the right location already
159 if os.readlink(lnkfile) == target:
160 continue
161 os.unlink(lnkfile)
162 elif os.path.exists(lnkfile):
163 # File/dir exists with same name as link, just leave it alone
164 continue
165 os.symlink(target, lnkfile)
166 newlinks.append(symsplit[0])
167 # Hide the symlinks from git
168 try:
169 git_exclude_file = os.path.join(s_dir, '.git/info/exclude')
170 if os.path.exists(git_exclude_file):
171 with open(git_exclude_file, 'r+') as efile:
172 elines = efile.readlines()
173 for link in newlinks:
174 if link in elines or '/'+link in elines:
175 continue
176 efile.write('/' + link + '\n')
177 except IOError as ioe:
178 bb.note('Failed to hide EXTERNALSRC_SYMLINKS from git')
179}
180
181python externalsrc_compile_prefunc() {
182 # Make it obvious that this is happening, since forgetting about it could lead to much confusion
183 bb.plain('NOTE: %s: compiling from external source tree %s' % (d.getVar('PN'), d.getVar('EXTERNALSRC')))
184}
185
186do_buildclean[dirs] = "${S} ${B}"
187do_buildclean[nostamp] = "1"
188do_buildclean[doc] = "Call 'make clean' or equivalent in ${B}"
189externalsrc_do_buildclean() {
190 if [ -e Makefile -o -e makefile -o -e GNUmakefile ]; then
191 rm -f ${@' '.join([x.split(':')[0] for x in (d.getVar('EXTERNALSRC_SYMLINKS') or '').split()])}
192 if [ "${CLEANBROKEN}" != "1" ]; then
193 oe_runmake clean || die "make failed"
194 fi
195 else
196 bbnote "nothing to do - no makefile found"
197 fi
198}
199
200def srctree_hash_files(d, srcdir=None):
201 import shutil
202 import subprocess
203 import tempfile
204 import hashlib
205
206 s_dir = srcdir or d.getVar('EXTERNALSRC')
207 git_dir = None
208
209 try:
210 git_dir = os.path.join(s_dir,
211 subprocess.check_output(['git', '-C', s_dir, 'rev-parse', '--git-dir'], stderr=subprocess.DEVNULL).decode("utf-8").rstrip())
Patrick Williams2390b1b2022-11-03 13:47:49 -0500212 top_git_dir = os.path.join(d.getVar("TOPDIR"),
213 subprocess.check_output(['git', '-C', d.getVar("TOPDIR"), 'rev-parse', '--git-dir'], stderr=subprocess.DEVNULL).decode("utf-8").rstrip())
Patrick Williams92b42cb2022-09-03 06:53:57 -0500214 if git_dir == top_git_dir:
215 git_dir = None
216 except subprocess.CalledProcessError:
217 pass
218
219 ret = " "
220 if git_dir is not None:
221 oe_hash_file = os.path.join(git_dir, 'oe-devtool-tree-sha1-%s' % d.getVar('PN'))
222 with tempfile.NamedTemporaryFile(prefix='oe-devtool-index') as tmp_index:
223 # Clone index
224 shutil.copyfile(os.path.join(git_dir, 'index'), tmp_index.name)
225 # Update our custom index
226 env = os.environ.copy()
227 env['GIT_INDEX_FILE'] = tmp_index.name
228 subprocess.check_output(['git', 'add', '-A', '.'], cwd=s_dir, env=env)
229 git_sha1 = subprocess.check_output(['git', 'write-tree'], cwd=s_dir, env=env).decode("utf-8")
Andrew Geisslerc5535c92023-01-27 16:10:19 -0600230 if os.path.exists(os.path.join(s_dir, ".gitmodules")) and os.path.getsize(os.path.join(s_dir, ".gitmodules")) > 0:
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500231 submodule_helper = subprocess.check_output(["git", "config", "--file", ".gitmodules", "--get-regexp", "path"], cwd=s_dir, env=env).decode("utf-8")
232 for line in submodule_helper.splitlines():
233 module_dir = os.path.join(s_dir, line.rsplit(maxsplit=1)[1])
234 if os.path.isdir(module_dir):
235 proc = subprocess.Popen(['git', 'add', '-A', '.'], cwd=module_dir, env=env, stdout=subprocess.DEVNULL, stderr=subprocess.DEVNULL)
236 proc.communicate()
237 proc = subprocess.Popen(['git', 'write-tree'], cwd=module_dir, env=env, stdout=subprocess.PIPE, stderr=subprocess.DEVNULL)
238 stdout, _ = proc.communicate()
239 git_sha1 += stdout.decode("utf-8")
Patrick Williams92b42cb2022-09-03 06:53:57 -0500240 sha1 = hashlib.sha1(git_sha1.encode("utf-8")).hexdigest()
241 with open(oe_hash_file, 'w') as fobj:
242 fobj.write(sha1)
243 ret = oe_hash_file + ':True'
244 else:
245 ret = s_dir + '/*:True'
246 return ret
247
248def srctree_configure_hash_files(d):
249 """
250 Get the list of files that should trigger do_configure to re-execute,
251 based on the value of CONFIGURE_FILES
252 """
253 in_files = (d.getVar('CONFIGURE_FILES') or '').split()
254 out_items = []
255 search_files = []
256 for entry in in_files:
257 if entry.startswith('/'):
258 out_items.append('%s:%s' % (entry, os.path.exists(entry)))
259 else:
260 search_files.append(entry)
261 if search_files:
262 s_dir = d.getVar('EXTERNALSRC')
263 for root, _, files in os.walk(s_dir):
264 for f in files:
265 if f in search_files:
266 out_items.append('%s:True' % os.path.join(root, f))
267 return ' '.join(out_items)
268
269EXPORT_FUNCTIONS do_buildclean