blob: 4595eafc6d5965ef17e57e8ec5ef08ebcdb692f2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master"
11SRCREV = "c9cb2a2289a6eb1fb95b66c25d5351bfea54c47e"
12
13S = "${WORKDIR}/git"
14
15# Same restriction as gtk+
16inherit features_check setuptools3
17ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
18
19inherit pkgconfig autotools python3native
20
21FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"