blob: b19482c79a80ff392563d29c00e141da8b838f0a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Copyright (C) 2020 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004SUMMARY = "Kronosnet, often referred to as knet, is a network abstraction layer \
5 designed for High Availability use cases, where redundancy, security, \
6 fault tolerance and fast fail-over are the core requirements of your application."
Andrew Geissler82c905d2020-04-13 13:39:40 -05007HOMEPAGE = "https://kronosnet.org/"
8LICENSE = "GPL-2.0+ & LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING.applications;md5=751419260aa954499f7abaabaa882bbe \
10 file://COPYING.libraries;md5=2d5025d4aa3495befef8f17206a5b0a1"
11SECTION = "libs"
12DEPENDS = "doxygen-native libqb-native libxml2-native bzip2 libqb libxml2 libnl lksctp-tools lz4 lzo openssl nss xz zlib zstd"
13
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014SRCREV = "b8d18c8360fd39cb04748e8bc1ee26de4afa4cbd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRC_URI = "git://github.com/kronosnet/kronosnet;protocol=https;branch=stable1"
16
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050017UPSTREAM_CHECK_URI = "https://github.com/kronosnet/kronosnet/releases"
18
Andrew Geissler5199d832021-09-24 16:47:35 -050019inherit autotools pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21S = "${WORKDIR}/git"
22
23# libknet/transport_udp.c:326:48: error: comparison of integers of different signs: 'unsigned long' and 'int' [-Werror,-Wsign-compare]
24# for (cmsg = CMSG_FIRSTHDR(&msg);cmsg; cmsg = CMSG_NXTHDR(&msg, cmsg)) {
25# ^~~~~~~~~~~~~~~~~~~~~~~
Patrick Williams213cb262021-08-07 19:21:33 -050026CFLAGS:append:toolchain-clang = " -Wno-sign-compare"
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050028PACKAGECONFIG[man] = "enable_man="yes", --disable-man, "
29
Patrick Williams213cb262021-08-07 19:21:33 -050030PACKAGECONFIG:remove = "man"