blob: 3339dc14210726525fb04aca2de27a6775454248 [file] [log] [blame]
Patrick Williams93c203f2021-10-06 16:15:23 -05001SUMMARY = "CHIPSEC: Platform Security Assessment Framework"
2
3DESCRIPTION = "CHIPSEC is a framework for analyzing the security \
4 of PC platforms including hardware, system firmware \
5 (BIOS/UEFI), and platform components."
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=bc2d1f9b427be5fb63f6af9da56f7c5d"
9
10SRC_URI = "git://github.com/chipsec/chipsec.git;branch=master \
11 "
12
13SRCREV = "b2a61684826dc8b9f622a844a40efea579cd7e7d"
14
15COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
16
17S = "${WORKDIR}/git"
18EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
19
20DEPENDS = "virtual/kernel nasm-native python3-setuptools-native"
21RDEPENDS:${PN} += "python3 python3-modules"
22
23inherit module distutils3
24
25do_compile:append() {
26 cd ${S}/drivers/linux
27 oe_runmake KSRC=${STAGING_KERNEL_BUILDDIR}
28}
29
30do_install:append() {
31 install -m 0644 ${S}/drivers/linux/chipsec.ko ${D}${PYTHON_SITEPACKAGES_DIR}/chipsec/helper/linux
32}
33
34FILES:${PN} += "${exec_prefix} \
35"