blob: 58994d709677a31a0e920acaeabe4cc56189624f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=439a07e400525964c3c82684146e46eb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslerc87764f2020-06-27 00:16:32 -050011inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} += " \
Andrew Geissler72956ed2021-01-08 16:11:14 -060018 ${PYTHON_PN}-math \
19"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050030SRC_URI[sha256sum] = "61b5ed1e22a0924aed1d23b478f37e8d52549ff8a961de2909c69bf950020cff"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32BBCLASSEXTEND = "native nativesdk"