blob: eda9381a54892388d1589c0338785ec7ed5b05e2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl ${PYTHON_PN}-cryptography"
7
Andrew Geisslereef63862021-01-29 15:58:13 -06008SRC_URI[sha256sum] = "4c231c759543ba02560fcd2480c48dcec4dae34c9da7d3747c508227e0624b51"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10PYPI_PACKAGE = "pyOpenSSL"
Patrick Williamsddad1a12017-02-23 20:36:32 -060011inherit pypi setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13PACKAGES =+ "${PN}-tests"
Patrick Williams213cb262021-08-07 19:21:33 -050014FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN}:class-target = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 ${PYTHON_PN}-cryptography \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20"
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN}-tests = "${PN}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23BBCLASSEXTEND = "native nativesdk"