blob: c85ae0497668b507828925d5494fcc5515db3087 [file] [log] [blame]
William A. Kennington IIIac69b482021-06-02 12:28:27 -07001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://add-with-bisonlocaledir.patch \
14 file://0001-Use-mapped-file-name-for-symbols.patch \
15 "
16SRC_URI[sha256sum] = "67d68ce1e22192050525643fc0a7a22297576682bef6a5c51446903f5aeef3cf"
17
18inherit autotools gettext texinfo
19
20# No point in hardcoding path to m4, just use PATH
21CACHED_CONFIGUREVARS = "ac_cv_path_M4=m4"
22
23PACKAGECONFIG ??= "readline ${@ 'textstyle' if d.getVar('USE_NLS') == 'yes' else ''}"
Patrick Williams213cb262021-08-07 19:21:33 -050024PACKAGECONFIG:class-native ??= ""
William A. Kennington IIIac69b482021-06-02 12:28:27 -070025
26# Make readline and textstyle optional. There are recipie for these, but leave them
27# disabled for the native recipe. This prevents host contamination of the native tool.
28PACKAGECONFIG[readline] = "--with-libreadline-prefix,--without-libreadline-prefix,readline"
29PACKAGECONFIG[textstyle] = "--with-libtextstyle-prefix,--without-libtextstyle-prefix,gettext"
30
31# Include the cached configure variables, configure is really good at finding
32# libreadline, even if we don't want it.
33CACHED_CONFIGUREVARS += "${@bb.utils.contains('PACKAGECONFIG', 'readline', '', ' \
34 ac_cv_header_readline_history_h=no \
35 ac_cv_header_readline_readline_h=no \
36 gl_cv_lib_readline=no', d)}"
37
38# The automatic m4 path detection gets confused, so force the right value
39acpaths = "-I ./m4"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041do_compile:prepend() {
William A. Kennington IIIac69b482021-06-02 12:28:27 -070042 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
43}
44
Patrick Williams213cb262021-08-07 19:21:33 -050045do_install:append:class-native() {
William A. Kennington IIIac69b482021-06-02 12:28:27 -070046 create_wrapper ${D}/${bindir}/bison \
47 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
48}
Patrick Williams213cb262021-08-07 19:21:33 -050049do_install:append:class-nativesdk() {
William A. Kennington IIIac69b482021-06-02 12:28:27 -070050 create_wrapper ${D}/${bindir}/bison \
51 BISON_PKGDATADIR=${datadir}/bison
52}
53BBCLASSEXTEND = "native nativesdk"