blob: 1ea6bb56e6d47b3defae79d0166101789aba3ca0 [file] [log] [blame]
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
16SRC_URI[sha256sum] = "10699f595eebb9410fd902908aa13aece19be5c437b405092be34f60f69f7999"
17
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
23 python3-sortedcontainers \
24 python3-statistics \
25 python3-unittest \
26 "
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 "
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/examples
34 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
35 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
36}
37
38BBCLASSEXTEND = "native nativesdk"