blob: f98c0b77228e6aad9805d5bec5efcc2a341efd02 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001BPN = "qemu"
2
Andrew Geisslerc926e172021-05-07 16:11:35 -05003inherit python3-dir
4
Brad Bishopc342db32019-05-15 21:57:59 -04005require qemu-native.inc
6
Brad Bishopc68388fc2019-08-26 01:33:31 -04007# As some of the files installed by qemu-native and qemu-system-native
Brad Bishopc342db32019-05-15 21:57:59 -04008# are the same, we depend on qemu-native to get the full installation set
9# and avoid file clashes
Andrew Geissler5199d832021-09-24 16:47:35 -050010DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native meson-native ninja-native"
Brad Bishopc342db32019-05-15 21:57:59 -040011
Patrick Williams213cb262021-08-07 19:21:33 -050012EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040013
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014PACKAGECONFIG ??= "fdt alsa kvm pie \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050015 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050016"
Brad Bishopc342db32019-05-15 21:57:59 -040017
18# Handle distros such as CentOS 5 32-bit that do not have kvm support
Patrick Williams213cb262021-08-07 19:21:33 -050019PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
Brad Bishopc342db32019-05-15 21:57:59 -040020
Patrick Williams213cb262021-08-07 19:21:33 -050021do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040022 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
23
24 # The following is also installed by qemu-native
25 rm -f ${D}${datadir}/qemu/trace-events-all
26 rm -rf ${D}${datadir}/qemu/keymaps
27 rm -rf ${D}${datadir}/icons/
Andrew Geisslerc926e172021-05-07 16:11:35 -050028
29 # Install qmp.py to be used with testimage
30 install -D ${S}/python/qemu/qmp.py ${D}${PYTHON_SITEPACKAGES_DIR}/qmp.py
Brad Bishopc342db32019-05-15 21:57:59 -040031}