blob: e7d8d70c2618442d14c1d8f465e31a1c4bb4135b [file] [log] [blame]
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05001require rust-target.inc
2require rust-source-${PV}.inc
3require rust-snapshot-${PV}.inc
4
5INSANE_SKIP:${PN}:class-native = "already-stripped"
6
7do_compile () {
8 rust_runx build --stage 2
9}
10
11rust_do_install() {
12 rust_runx install
13}
14
15python () {
16 pn = d.getVar('PN')
17
18 if not pn.endswith("-native"):
19 raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
20}