blob: b8c2946371adfe239cccb77da262044b4f4a821a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
William A. Kennington IIIac69b482021-06-02 12:28:27 -07005HOMEPAGE = "https://github.com/liberationfonts/liberation-fonts"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006BUGTRACKER = "https://bugzilla.redhat.com/"
7
8SECTION = "x11/fonts"
9LICENSE = "OFL-1.1"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b"
11PE = "1"
12
William A. Kennington IIIac69b482021-06-02 12:28:27 -070013SRC_URI = "https://github.com/liberationfonts/liberation-fonts/files/6418984/liberation-fonts-ttf-${PV}.tar.gz \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://30-liberation-aliases.conf"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070015SRC_URI[sha256sum] = "26f85412dd0aa9d061504a1cc8aaf0aa12a70710e8d47d8b65a1251757c1a5ef"
16UPSTREAM_CHECK_URI = "https://github.com/liberationfonts/liberation-fonts/releases"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
19
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020inherit allarch fontcache
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021
22do_install () {
23 install -d ${D}${datadir}/fonts/ttf/
24 for i in *.ttf; do
25 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
26 done
27
28 install -d ${D}${sysconfdir}/fonts/conf.d/
29 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
30
31 install -d ${D}${prefix}/share/doc/${BPN}/
32 install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/
33}
34
35PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050036FILES:${PN} += "${sysconfdir} ${datadir}"
Brad Bishop19323692019-04-05 15:28:33 -040037
38BBCLASSEXTEND = "native nativesdk"