blob: 4e9be5e37f06cbde01bedc358acbe3337116cd92 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
Andrew Geissler09036742021-06-25 14:25:14 -050011LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geisslerc182c622020-05-15 14:13:32 -050013DEPENDS = "libevdev udev mtdev libcheck"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
Andrew Geisslerc182c622020-05-15 14:13:32 -050016 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 file://determinism.patch \
18 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050019SRC_URI[sha256sum] = "9ca14021fbc2523bc0610582c51f368321592040b6ca63becc2fa1ea11f1a7cb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
Andrew Geisslerc182c622020-05-15 14:13:32 -050023inherit meson pkgconfig lib_package ptest
24
25# Patch out build directory, otherwise it leaks into ptest binary
Patrick Williams213cb262021-08-07 19:21:33 -050026do_configure:append() {
Andrew Geisslerc182c622020-05-15 14:13:32 -050027 sed -i -e "s,${WORKDIR},,g" config.h
28 if [ -e "litest-config.h" ]; then
29 sed -i -e "s,${WORKDIR},,g" litest-config.h
30 fi
31}
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
35PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
36
37UDEVDIR = "`pkg-config --variable=udevdir udev`"
38
39EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
40 -Ddocumentation=false \
Andrew Geisslerc182c622020-05-15 14:13:32 -050041 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 -Dzshcompletiondir=no"
43
44# package name changed in 1.8.1 upgrade: make sure package upgrades work
Patrick Williams213cb262021-08-07 19:21:33 -050045RPROVIDES:${PN} = "libinput"
46RREPLACES:${PN} = "libinput"
47RCONFLICTS:${PN} = "libinput"
Andrew Geissler82c905d2020-04-13 13:39:40 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"