blob: 90a8d7dfbb92044577baa5daec99755980cdcf4c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require gstreamer1.0-plugins-common.inc
2
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "'Base' GStreamer plugins and helper libraries"
4HOMEPAGE = "https://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006LICENSE = "GPLv2+ & LGPLv2+"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
10 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
11 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
12 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
13 file://0004-glimagesink-Downrank-to-marginal.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016SRC_URI[sha256sum] = "29e53229a84d01d722f6f6db13087231cdf6113dd85c25746b9b58c3d68e8323"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18S = "${WORKDIR}/gst-plugins-base-${PV}"
19
20DEPENDS += "iso-codes util-linux zlib"
21
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022inherit gobject-introspection
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24PACKAGES_DYNAMIC =+ "^libgst.*"
25
26# opengl packageconfig factored out to make it easy for distros
27# and BSP layers to choose OpenGL APIs/platforms/window systems
28PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
29
30PACKAGECONFIG ??= " \
31 ${GSTREAMER_ORC} \
32 ${PACKAGECONFIG_GL} \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
34 jpeg ogg pango png theora vorbis \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
36"
37
38OPENGL_APIS = 'opengl gles2'
39OPENGL_PLATFORMS = 'egl'
40
41X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
42X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
43X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
44
45PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
46PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
47PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
48PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
49PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
50PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
51PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
52PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
53PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
54PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
55PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
56PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
57
58# OpenGL API packageconfigs
59PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
60PACKAGECONFIG[gles2] = ",,virtual/libgles2"
61
62# OpenGL platform packageconfigs
63PACKAGECONFIG[egl] = ",,virtual/egl"
64
65# OpenGL window systems (except for X11)
66PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
67PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
68PACKAGECONFIG[dispmanx] = ",,virtual/libomxil"
Andrew Geisslerc926e172021-05-07 16:11:35 -050069PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050070
Andrew Geisslerc926e172021-05-07 16:11:35 -050071OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050072
73EXTRA_OEMESON += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060074 -Ddoc=disabled \
Andrew Geissler82c905d2020-04-13 13:39:40 -050075 -Dgl-graphene=disabled \
76 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
77 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
78 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
79"
80
Patrick Williams213cb262021-08-07 19:21:33 -050081FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
82FILES:${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
Andrew Geissler82c905d2020-04-13 13:39:40 -050083
84def get_opengl_cmdline_list(switch_name, options, d):
85 selected_options = []
86 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
87 for option in options.split():
88 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
89 selected_options += [option]
90 if selected_options:
91 return '-D' + switch_name + '=' + ','.join(selected_options)
92 else:
93 return ''
Andrew Geissler6ce62a22020-11-30 19:58:47 -060094
95CVE_PRODUCT += "gst-plugins-base"